NextGEN Gallery
[resolved] Still can not upload new photos! (24 posts)

  1. smolby5697
    Posted 2 years ago #

    I have been waiting for a fix on this plugin since WP 3.6 update.
    Still having issues, should I just start over with a different gallery or is there going to be a fix???????


  2. kenwiesner
    Posted 2 years ago #


    I too am having issues with uploading images. I have 40+ sites where the plugin is being used and all of them are experiencing the same issue.

    When you go to Add Gallery / Images and try to upload an image, there is a little warning triangle that pops up on the line with the file and then a toast pops up that says "Upload Complete, 0 images were uploaded." I looked in php error log and I'm not seeing anything in there. When I debug the page in Chrome though, it looks like when you load the page, there are resources missing:

    GET http://*/wp-admin/jquery-1.10.2.min.map 404 (Not Found)
    POST http://*/photocrati_ajax 404 (Not Found)

    Then when you try to upload, the console appends this:

    POST http://*/photocrati_ajax?action=upload_image&gallery_id=0&gallery_name=test 404 (Not Found)

    This is a CLEAN install of WP 3.6 with Twenty Twelve Theme with ONLY NextGen Gallery 2.0.17 installed. If anyone from Photocrati would like to log in and experience this for themselves, I'm happy to provide access.

    Server Settings for Reference:

    Operating System : Linux (64 Bit)
    Server : Apache/2.2.14 (Ubuntu)
    Memory usage : 38.82 MByte
    MYSQL Version : 5.1.70-0ubuntu0.10.04.1-log
    SQL Mode : Not set
    PHP Version : 5.3.2-1ubuntu4.21
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 512
    PHP Max Upload Size : 80M
    PHP Max Post Size : 80M
    PCRE Backtracking Limit : 500000
    PHP Max Script Execute Time : 30s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes
    Graphic Library

    GD Version : 2.0
    FreeType Support : Yes
    FreeType Linkage : with freetype
    T1Lib Support : Yes
    GIF Read Support : Yes
    GIF Create Support : Yes
    JPEG Support : Yes
    PNG Support : Yes
    WBMP Support : Yes
    XPM Support : No
    XBM Support : No
    JIS-mapped Japanese Font Support : No

  3. caligolfer2004
    Posted 2 years ago #

    I am having the same issue. When uploading an image to any gallery I have on my website, it says the image has uploaded but then a little oval shaped pop up occurs and it says 0 images added.

    When is this going to be fixed? If not soon can anyone suggest another gallery plugin to use?

  4. swiftouch
    Posted 2 years ago #

    I can only upload photos if the folders are set to 777. Unfortunately, a spammer-hacker has uploaded malware to this site 3 times now...every time I set ANY folder to 777 BAM, my firewall's IP is on blacklists and it's spamming like mad.

    I've tried setting permissions to 770. One commenter suggested that in a previous post. No dice. Didn't work.

    I've tried adding .htaccess to the gallery/ folder...
    <Files ^(*.jpeg|*.jpg|*.png|*.gif)>
    order deny allow
    deny from all
    That doesn't work either. The thumbnails in the gallery admin no longer show.

    What is it about this server that makes wordpress so damn frustrating. On this same server I have to enter the FTP login every time i update a plugin or base wordpress files. And half the time it fails.

    What permissions do I need to open up so wordpress doesn't suck so bad.

  5. swiftouch
    Posted 2 years ago #

    Ok so my frustrations are alleviated.

    As it turns out php is being run on my server as the apache user "www"
    <?php echo(exec("whoami")); ?>

    All I had to do to fix the problem was chown all of the files and folders to www:linuxusername
    instead of

    The commands to chown files / folders on freebsd distro (i'm a noob and havent used other distros so wouldn't know how to do it on those.

    chown -R www:linuxuser public_html/*
    * = suppresses changing public_html/ folder.

    Meaning now its running all the files and folders as the www user which HAS permission.

    This is where I found the fix: (and a more detailed explanation)

    If this is a security issue let me know. For now I'll run with it since it's the first time I've EVER been able to update wordpress (from within the admin) without it requiring the FTP. And setting folder permissions to 777... (which is a REALLY big security issue)

    This also took care of (fixed) the nextgen upload issues I was experiencing where i'd hit upload and it would say http error.

  6. frisco
    Posted 2 years ago #

    @kenwiesner - You pointed out a 404 error with this file.

    GET http://*/wp-admin/jquery-1.10.2.min.map 404 (Not Found)

    This is a WP 3.6 bug that is likely to be fixed in WP 3.6.1. It has nothing to do with NGG.

    @swiftouch - Yes, it's a security issue. Whenever you can update WP or plugins via the UI, you are accepting weaker security than if that were not allowed. The change you made did lower you security. Whether someone will exploit that can only be known in time.

  7. photocrati
    Plugin Author

    Posted 2 years ago #

    @frisco & @swiftouch - Thanks for the input and the feedback. Great information to share.

    - Cais.

  8. kenwiesner
    Posted 2 years ago #

    @frisco, is there no work around for this? We have 168 sites running NextGen gallery and NONE of them are able to upload new photos nor have they been able to for over a month. Our customers are screaming at us, we desperately need a solution. Appreciate any insight you can offer.

    All the best,


  9. kenwiesner
    Posted 2 years ago #

    Also @frisco and @photocrati, from what I've been reading on this matter, this is NOT a WordPress bug but rather a bug in the plugin.


  10. frisco
    Posted 2 years ago #

    @kenwiesner - My comment was related to this element of your error message:

    GET http://*/wp-admin/jquery-1.10.2.min.map 404 (Not Found)

    See trac ticket 24994, and that is definitely a WP error that was fixed in WP 3.6.1. However, that should not impact uploading files. (It simply generated a 404 error, which you'd only see if you cared to look.)

    We do have the latest release of NGG running under WP 3.7 alpha on one of our networks, and we have no issues with uploading files. That makes me think the cause of your situation is either a plugin conflict or tied to your server setup.

    Your link to the other discussion of jquery issues is interesting but possibly unhelpful, since it involves javascript from other plugins. I recommend you take a site running a default WP theme (such as Twenty Twelve or Twenty Thirteen) and make NGG the only active plugin. Then, test NGG functionality. If NGG doesn't work in that barebones install, my next step would be to submit a bug report directly to the Photocrati people. Admittedly, they are getting a lot of these bug reports, so be patient. They're doing a great job working through them. (And as a sidenote, we bought the premium NGG Pro as a small gesture of support because of how openly they've handled the 2.0 upgrade issues.)

    I know a fair amount about NGG, but your best bet to get NGG issues resolved is working directly with the Photocrati team and the others that help out in these forums. Sorry to hear of your customer issues. Any discussion we might have about resolving them would have to take place outside these forums.

    Hope that helps.

  11. kenwiesner
    Posted 2 years ago #

    OK so the jQuery error is gone with 3.6.1 but there is still prob with the AJAX script for NGG. http://d.pr/i/dkaJ Not sure what is causing it but this is on a CLEAN install of WP 3.6.1 with latest NGG.

  12. frisco
    Posted 2 years ago #

    @kenwiesner - One thing struck me from your image link - are aware that the uploading workflow has changed slightly? That is, you have to specify a gallery to which you want to upload the images OR you have to specify a new gallery name. If you don't do one or the other, nothing will upload. I raise this because your gallery name field is blank and your pull down shows you want to upload to a new gallery. Those 2 things aren't compatible.

    In my tests, attempting to upload without following that workflow would not trigger a 404 (just a 400), so that doesn't fully explain what you're seeing. You could check your /wp-includes/jquery folder for the jquery-migrate.js script. I suppose if that's missing it might trigger a 404 error, but I didn't test that. If it is missing, that's not an NGG issue - that's because your core update of WP wasn't perfect, which could have been something as simple as an FTP error.

    If you did follow the workflow and the migrate script is where it should be, your best bet is to send Photocrati a bug report with a link to the site. You might expedite the process by creating a user account with administrator role for their support team and including the credentials (both username & password) to log in. I don't know what they require or will make use of, so those are just general tips.

  13. hoven002
    Posted 2 years ago #

    I experience the same problem here after upgrading to WordPress 3.6.1.

    1. Add a new gallery and give it a name
    2. Add files
    3. Start upload

    The result is:

    In the chrome debug-tool I see also an error 400:

    Does anyone have a suggestion what the problem can be?
    Thanks in advance.


  14. hostakm
    Posted 2 years ago #

    @hoven002: I have the same problem, no solution yet :/

  15. JorritSchippers
    Posted 2 years ago #

    I got this while using nginx. The reason is $_SERVER['PATH_INFO'] was an empty string, causing the router to not read the location correctly and serve /photocrati_ajax.

    Quick fix: edit products/photocrati_nextgen/modules/router/class.router.php and replace if (isset($_SERVER['PATH_INFO'])) with if (!empty($_SERVER['PATH_INFO'])) in function get_request_uri.

  16. TheTou
    Posted 2 years ago #

    @JorritSchippers: Thank you! This solved the problem for me!

  17. omniamediahrc
    Posted 2 years ago #

    i got No permissions to upload images. Try refreshing the page or ensuring that your user account has sufficient roles/privileges.
    just pissed of beyond belief with this plugin already :|

  18. walmirino
    Posted 1 year ago #

    This problem is not permission. This problem is the plugin configuration.

    Go to:

    Gallery> Other options

    See if this directory: wp-content/gallery/
    Switch to: /wp-content/gallery/


  19. photocrati
    Plugin Author

    Posted 1 year ago #

    @walmirino - Thanks for the tip ... was there a reason you posted this on a six month old topic?

    - Cais.

  20. walmirino
    Posted 1 year ago #

    I did not find a solution to this problem in another topic, and spent more than 24 hours to figure out, you can now lock the topic.

    Thank you

  21. photocrati
    Plugin Author

    Posted 1 year ago #

    @walmirino - Thanks! Hopefully this will not get lost in this topic.

    Also to note, only forum moderators can lock (read: close) a topic. We cannot.

    - Cais.

  22. Turbojohan
    Posted 1 year ago #

    No, walmirions solution did not work for me :(

    I just get this error message all the time:
    "No permissions to upload images. Try refreshing the page or ensuring that your user account has sufficient roles/privileges."

    Have spent many hours reading och trying to solve this...
    Setting gallery folder to 777 didnt work either...

  23. Turbojohan
    Posted 1 year ago #

    I run the site local with wamp and got exactly the same error.

    My final sollution was to downgrade to 1.9.13.

    I just deleted all files from current version and uploaded the files of 1.9.13 and voila, it all worked again! ;)

    This is acceptable by now, but I really hope they can fix version 2 to be more stable and with less bugs...

  24. photocrati
    Plugin Author

    Posted 1 year ago #

    @Turbojohan - As it, it would be best to continue any reports of your issue(s) in your own topic(s).


    - Cais.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic