Support » Plugin: Shortcode in Menus » Still Broken Update 3.2

  • Hi

    no, since the update to 3.2 it’s no longer working. It is just showing the shortcode in the menu instead of what it’s supposed to show.

    3.1 was working fine.

    I have updated the plugin to 3.2 at which point it no longer functioned. I have tried deactivating and reactivating it. I have also tried deleting the plugin and reinstalling it. Same results.

Viewing 4 replies - 16 through 19 (of 19 total)
  • Hi Gagan,

    Thanks for putting up the 3.1 version.
    It’s working again with these files.

    Gagan this looks like a potential suspect.

    I just restored my site back to a recent backup with version 3.1 running and activated. I updated shortcodes in menu plugin to 3.2, hoping to get the error.

    It updated ok. I refreshed the plugin page and I got the error. This time I got a screenshot.

    Shortcode plugin error

    Ok so I just reactivated the plugin, and the error did not come back this time.

    However now the shortcodes in the menu are working okay.

    Either you updated something on the plugin and I just downloaded a fixed update?

    Or, potentially the plugin was deactivating itself without me knowing. But I don’t think this is possible, because like I said, yesterday I deactivated and reactivated it many times, and even uninstalled and reinstalled the updated version.

    So there is definitely something strange going on with the plugin (unless you just updated something with it). If the error comes back I will report back here, and if the links stop working again I will report back here. I am here if you need any further info or testing done, just leave a reply.

    Plugin Author Gagan Deep Singh

    (@gagan0123)

    Volunteer Moderator

    @manm0untain

    Its really great to know that its working for you again 🙂

    About the error you saw, it was reported earlier as well, and was caused due to refactoring of the code. I was automating a lot of things and that required me to go with the skeleton structure I’ve built for plugins and I had to make sure all my plugins are following that structure. It was reported earlier and simply activating the plugin again, works as described here:

    https://wordpress.org/support/topic/broken-update-3/

    About fixing the update, well, I haven’t, here’s the link to the SVN repo for the same:
    https://plugins.trac.wordpress.org/browser/shortcode-in-menus/

    You can see, last update was 43 hours ago, when I initially released the 3.2 version.

    Let it be, I’m happy that its working for you, and thats all that matters 🙂

Viewing 4 replies - 16 through 19 (of 19 total)
  • The topic ‘Still Broken Update 3.2’ is closed to new replies.