• manm0untain

    (@manm0untain)


    Hi

    no, since the update to 3.2 it’s no longer working. It is just showing the shortcode in the menu instead of what it’s supposed to show.

    3.1 was working fine.

    I have updated the plugin to 3.2 at which point it no longer functioned. I have tried deactivating and reactivating it. I have also tried deleting the plugin and reinstalling it. Same results.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Gagan Deep Singh

    (@gagan0123)

    manm0untain

    Can you please try this shortcode
    [gs_test_shortcode]
    and let me know if it shows “http://gagan.pro” on the frontend or not?

    Whether it does or not, can you also please mention the shortcode you’re trying to use and which version of WordPress you’re using it with?

    Plugin Author Gagan Deep Singh

    (@gagan0123)

    I’ve just now tested it out with WordPress 4.7.5, installing directly from WordPress.org, on this dev site
    http://shortcodeinmenus.dev.gagan.pro/
    and it appears to be working as of now.

    Plugin Author Gagan Deep Singh

    (@gagan0123)

    Here are the screenshots of the menu items I created:

    Custom Link
    Shortcode Menu Item

    Thread Starter manm0untain

    (@manm0untain)

    Yes, that is great for you. But not so great for me, because for me it is not working.

    I am quite aware how to add a shortcode. As I said, the menus created with the previous version were working fine.

    Since upgrading to the current version, they are not working. It is just adding the shortcode into the menu item URL, instead of the code behind the shortcode. Details posted above. I had also tested with your [gs_test_shortcode] and that did not work either. WordPress version 4.7.5

    I have since rolled back to a backup running 3.1 of this plugin and it is once again working.

    If one person is reporting an issue, guaranteed 1000 other people are experiencing the issue but not reporting it. Please look into this issue thanks.

    Thread Starter manm0untain

    (@manm0untain)

    Ok to help with testing I have re-updated the plugin to 3.2 version. Once again it has stopped working.

    I am using Buddypress Profile Shortcodes. I have also re-tested your gs test shortcode, that is also not working still.

    Here are some images of what’s happening.

    Version 3.1 Working
    Version 3.2 not working

    Plugin Author Gagan Deep Singh

    (@gagan0123)

    manm0untain

    In both the images, the version thats being displayed is the 3.2(in the plugins list).

    Trying my best to re-create the issue you are facing, one guess I’m having is, it could be opcache, if its configured to ignore the timestamps on PHP files, this is usually done on production servers where PHP files are not going to change, but to resolve the issue, all thats needed is reload the PHP FPM.

    Can you please provide me with the list of plugins you’re using on the site, so that I can try to create a testing environment with the same?

    Plugin Author Gagan Deep Singh

    (@gagan0123)

    manm0untain

    I’ve added BuddyPress and Buddypress Profile Shortcodes plugins on the test site, and yet, everything is working.

    Here are the screenshots:
    Admin screen
    Frontend 1
    Frontend 2

    Thread Starter manm0untain

    (@manm0untain)

    Sorry I screwed up the image I made for 3.1, but rest assured the top image was 3.1 and the bottom was 3.2. I can do it again if you really need it. I have already restored back to 3.1

    Again, I don’t know what to tell you. It’s working for you, that’s great as long as you are the only person using it. As it stands, it is not working for me as soon as I upgrade it. You can tell me it’s working for you a million times, doesn’t do anything to identify why it’s not working for me, and probably loads of other people too. Shame because 3.1 worked fine with no problems, and gave a good solution to the problem of having shortcodes in menus. Now I will have to use 3.1 or find a different solution, unless you can figure out where the problem is.

    Plugin Author Gagan Deep Singh

    (@gagan0123)

    manm0untain

    Buddy, I really need to find the error, since you are having it, and it could be that other people also might, at least you are trying to help making the plugin better by reporting the issue and helping me debug it.

    Just so you know, I’ve tested the plugin with the following setups:

    • PHP5.6 WP4.7.5
    • PHP5.6 WP4.5
    • PHP7.0 WP 4.7.5
    • PHP7.1 WP 4.7.5

    Both with and without these two plugins

    • BuddyPress
    • Buddypress Profile Shortcodes

    Unless I’m able to replicate the issue you’re having, its like becoming something like throwing darts in the dark, with no idea where your target is.

    Could you help me out with the following:

    1. PHP Version
    2. MySQL Version?
    3. List of all the plugins
    4. Active Theme

    Having this, I’ll try to create a test rig, with exactly your setup, maybe one of the plugins or theme is acting out differently to the new update.

    The birdman

    (@fenix5000)

    I confirm the issue is happening for only in firefox and IE.
    It’s working correctly in Chrome.
    It happend for me to right after the update to 3.2

    But the website of the creator of this post is not working in all browsers for me.

    So it’s a bit weird.

    -No buddypress installed

    Plugin Author Gagan Deep Singh

    (@gagan0123)

    Fenix5000

    Thanks for your input, testing it out in Firefox(sorry no IE)

    The birdman

    (@fenix5000)

    Hi Gagan, thanks for looking into this.

    Can i download the 3.1 version somewhere in meantime so i can get back online again?

    Plugin Author Gagan Deep Singh

    (@gagan0123)

    @fenix5000

    I tested out in Firefox also, I was using Firefox Developer edition, it was working in that, so I installed the normal edition of Firefox as well, just to check out if thats the case.

    Here’s the screencast I made for the testing, still puzzled, how its not working, since what I did was basically move two files in different folders and changed the include path. Logically does not making any sense to me.

    Just in case you want to use the older version of the plugin, here’s the link:
    https://downloads.wordpress.org/plugin/shortcode-in-menus.3.1.zip

    Will test it out in Windows as well, and make screencast for the same and share here the results, whether it works or not.

    Thread Starter manm0untain

    (@manm0untain)

    Hi Gagan

    of course I am happy to help you debug this, I need it 🙂

    I was deactivating my plugins, I saw something very quickly just as the page was loading. It said something like ‘shortcodes in menus has been deactivated due to an invalid header’, and the shortcodes plugin had been deactivated. I tried to reactivate it again to get the same error but so far it has not come back.

    So here is some more info:

    Wordpress version 4.7.5
    PHP version 5.6.30
    MySQL version 5.0.11

    Theme: Kleo

    I tried to test it in a different theme but these menus are set up in Kleo so it will be hard. Maybe Fenix5000 can test that part?

    Plugins I have a lot:

    Activity Reactions For Buddypress
    Agreeable
    Akismet Anti-Spam
    Arconix FAQ
    bbPress
    BP Group Documents
    BP Profile Search
    BP Redirect To Profile
    BP Sticky Groups
    BuddyBoss Inbox
    BuddyPress
    BuddyPress Activity Autoloader
    BuddyPress Extended Friendship Request
    BuddyPress Featured Members
    BuddyPress First Letter Avatar
    BuddyPress Global Search
    BuddyPress Group Email Subscription
    BuddyPress Profile Shortcodes
    Buddypress User Blog
    BuddyPress Usernames Only
    BuddyPress Xprofile Custom Fields Type
    Contact Form 7
    Easy Custom Sidebars
    Essential Grid
    GD bbPress Attachments
    K Elements
    Import users from CSV with meta
    Location Autocomplete for BuddyPress
    Loginizer
    Mailster – Email Newsletter Plugin for WordPress
    Nav Menu Roles
    No Disposable Email
    rtMedia for WordPress, BuddyPress and bbPress
    SecuPress — WordPress Security (PAID?)
    SeedProd Coming Soon Page Pro
    Shortcodes in Menus
    Slider Revolution
    Theme Check
    Transcoder
    UpdraftPlus – Backup/Restore
    User notes
    W3 Total Cache
    Wordfence Security (PAID?)
    WP Bannerize pro
    WP Mail SMTP
    WP Smush
    WPBakery Visual Composer
    Yoast SEO

    However, I have now deactivated most all of my plugins to check this. Now I am running only:

    Buddypress
    Buddypress profile shortcodes
    Buddypress usernames only
    Loginizer
    Nav Menu Roles
    Shortcodes in menu

    And the problem is the same.

    I think the problem might be with that error I mentioned at the top. It still has not come back, otherwise I would have gotten a screen shot for you.

    Link in different browsers

    Plugin Author Gagan Deep Singh

    (@gagan0123)

    @manm0untain

    Thanks for the detailed list, I’ll be setting up a test server now with these details 🙂

    Hopefully will find and crush the bug.

    PS: There’s no harm inflicted on any animal or insect while writing this comment nor is intended to.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Still Broken Update 3.2’ is closed to new replies.