Support » Plugin: WPGlobus - Multilingual Everything! » Stil overwrites other language in Gutenberg

  • Hi,

    I read a couple of similar problems and your answer, but basically I don’t see how people get it working. If i edit one language, it overwrites the other, in my posts, pages and cpt’s. I tried using the “classic Editor” plugin but that doesn’t work, also I think that is a workaround, not a solution… It doesn’t matter which theme I use, It doesn’t work in any of ’em. My base language is Dutch and my added language is English.

    What is the combination of settings (Post types, Compatibility, Block Editor) you as plugin authors say are needed to get the claimed Gutenberg compatibility? I am a developer so additions in code are also ok.

    THX

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor Alex Gor

    (@alexgff)

    Thx for your quick reply. Yes I did, and I did try the Classic Editor (btw you forgot to mention that the default plugin settings should be changed in WP Settings > Read). But apart from that being a workaround and not a solution, it doesn’t work. Any setup I try, changed English overwrites Dutch and the way around. I switched themes, deactivates all plugins, nothing works.

    It did work before with this same setup by the way, I already have translated pages that show both languages, but when I change any of them, they also overwrite the other. I also downgraded the plugin to 2.2.29 and to 2.1.15 , without any luck.

    AS I said, it used to work last year, I think November (this project was on hold for a while).

    By the way, the pages that are already translated do show in the front-end, because the menu language switcher does work as expected.

    Plugin Contributor Alex Gor

    (@alexgff)

    You can send an email to us.

    did so

    took the time to sent you an e-mail explaining the whole issue again, and you replied with a single sentence: “I can help if you provide me with an administrator access to your website.”

    I guess you know this is not good practice and is strongly advised against by worpdress.org. Also, if you have any suggestions to look for, I can do that. So let’s try again…

    I deactivated all other plugins and switched to Twenty Nineteen theme, and updated the plugin to the latest version. The problem remains: I create a blog post (standard post) in the default language, save it, switch to another language, edit, and save. The default language is overwritten, and the other language is empty again.

    WordPress version 5.3.2
    WPGlobus version 2.2.32
    Worpdress Health Check plugin shows no problems.

    Your help is appreciated

    Plugin Contributor Alex Gor

    (@alexgff)

    Hi,

    Thanks for the reply. But I already tried that, see above, and it doesn’t work. Also, I don’t want to use the classic editor, I want to use Worpdress 5 as it’s supposed to be.

    I just installed WPGlobus on another WP site on the same server, and that one works as expected. So there must be something in my website. The difference between both is the default WPGlobus language in the new install is English, and in the added language is Dutch. IN the other (not working) site it’s the other way around, though both sites are in dutch. So, what can I look for?

    And to go back your solution, what does this mean:

    5. But may there is problem with Classic Editor plugin (probably it depends on your options).

    thx.

    Plugin Contributor Alex Gor

    (@alexgff)

    > what does this mean:
    This means
    If you don’t see links ( arrow 2 ) then you should open Classic Editor settings page and set Allow users to switch editors option to Yes.

    OK, that is what is says under 5. I tried that, Shouldn’t have asked. I saw the editor options and treid them. BUt as I said , it did not solve anything. Any options?

    I juat tried: De-installing WPGlobus, remove everything related to WPGlobus in the database using MySQL, and re-installing WP.Globus. Didn’t help.

    Plugin Contributor Alex Gor

    (@alexgff)

    1. PHP version ?
    2. is enabled MBString extension ?

    Hi,
    1. PHP Version is 7.3
    2. Yes, MBString is enabled.

    And I sent you an e-mail 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.