Support » Plugin: Recent Posts Widget With Thumbnails » Sticky to top

  • Resolved sjoerd89

    (@sjoerd89)


    Hi there,

    i am showing two categories of posts on my frontpage (“nieuws” and “nieuwsbrief”).
    Both of the categories have 3 thumbnail posts showing. If i make a post sticky and set the options to : Keep sticky posts on top of the list – on , i do not see any changes.

    The post that is suppose to be sticky will not go to the top.
    Any idea what i am doing wrong here? I saw an old post about this but didn’t get the solution from there.

    Sjoerd

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Martin Stehle

    (@hinjiriyo)

    Unfortunately it is not possible to set sticky posts on top if the category filter is in use.

    But if i remove the category, then the post will not show at all because it is set to show a certain category right?

    Is this option available in the pro version?

    Plugin Author Martin Stehle

    (@hinjiriyo)

    You can not remove a category in this filter, but you can set it to “All categories” (first item in the selection list). Then the Sticky options will work.

    This is not available in the Pro version, too. Both plugins use the WordPress core function to fetch a list, and the core function does not place any post on top of the list if a category is specified.

    Thanks for the clear answers like always!

    Plugin Author Martin Stehle

    (@hinjiriyo)

    Sjoerd, the plugin is indeed capable to put sticky posts on the top of the list, even if the list is filtered by category. It considers sticky posts of the selected categories only. I can reconstruct that on my server.

    I added this feature a long time ago and forgot it. Sorry for any confusion.

    So the question is why that does not work on your server. Are the other options for sticky posts deactivated?

    Plugin Author Martin Stehle

    (@hinjiriyo)

    I can’t reconstruct your case. Without knowing your WP installation I just can assume that another function interferes during the query.

    sjoerd89

    (@sjoerd89)

    What can i tell you to help you out with this?

    sjoerd89

    (@sjoerd89)

    Hello Martin,

    any idea what i can do to figure this out?

    Plugin Author Martin Stehle

    (@hinjiriyo)

    If I would be you, I would search in the theme PHP files and all plugins PHP files of your WordPress installation for “sticky” and go on depending on the result.

    sjoerd89

    (@sjoerd89)

    Thanks for the info, i will relay this in my theme GeneratePress. Just like you someone who is always trying to help. I will close it here on your part.

    Thanks for the info!

    Hello Martin,

    i re-opened this question because i have tried it with the theme owner (generatepress) and he is saying they do not do anything with the sticky part.
    I looked in my own CSS and the only sticky i use is :

    nav.main-navigation .sticky-logo img {
        height: 95px !important;
        padding-top: 20px !important;
        padding-left: 105px !important;
    }

    Then i went to check if my pagebuilder was stopping my post from being sticky, i put the widget in a new sidebar on a testpage without any pagebuilder: https://www.zilvertron.com/keuzepagina/
    The “Tech-torials” post is sticky but still not showing on top.

    I am lost again :p any idea what to do now?

    Plugin Author Martin Stehle

    (@hinjiriyo)

    Are thee sticky posts on top of the list if you use the WordPress standard widget “Recent Posts”, at least on the home page?

    Okay Martin i got it working. But do not ask me why this works ;).
    This is what i did.

    https://i.imgur.com/AZkcdhw.png

    I changed the category from 1 of the widgets within the pagebuilder and that actually made the sticky go to the top. Then i changed the other one to the other category so now they are switched around.

    Thanks for all the help! If i could rate again i would.

    Sjoerd

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.