Support » Theme: BoldR Lite » Sticky Post on all pages

  • Resolved ronelld.regen

    (@ronelldregen)


    Hey Boldr Lite users and developers,
    first of all, Happy New Year for everyone. While enjoying my christmas holiday, I spent some time with customizing BoldrLite Theme by a child theme. I’m happy with most parts of it.

    But unfortunately, there is a problem with the sticky posts. On the first page, the sticky post is displayed in a box (as intended). But on the second blog page, the box isn’t displayed. On the third page there is no sticky post anymore. What’s the reason for that behaviour. Do you have any ideas???

    Box around sticky post on top: http://design.praetz.net
    No box around sticky on 2nd page: http://design.praetz.net/page/2/
    No sticky post at all: http://design.praetz.net/page/3/

    Here is a small excerpt from my index.php…

    ?><div class="post-content"><?php
        if ( get_post_format() || post_password_required() || "Full content" == boldr_get_option('blog_index_shows') || is_sticky() == True)
          the_content();
        else the_excerpt();
        if (has_tag())
          the_tags('<br class="clear" /><div class="tags"><span class="the-tags">'.__('Tags', 'boldr').':</span>', '', '</div>');
        endif;
    ?></div><?php

Viewing 7 replies - 1 through 7 (of 7 total)
  • Theme Author Mathieu Sarrasin

    (@iceable)

    Hello,

    This is actually the expected behavior of sticky posts in WordPress. I admit the fact that your post reappears without sticky style on the second page looks confusing at first but there’s actually an explanation as well:

    – Sticky posts appear at the top of the front page, with “sticky” styling, but only on the first page of the blog index.

    The “sticky” class is only added for sticky posts on the first page of the home page (is_home() is true and is_paged() is false).

    http://codex.wordpress.org/Sticky_Posts#Style_Sticky_Posts

    – Sticky posts appear a second time as “normal” (without sticky styling) where they should normally be based on their post date. This is what happens with your post on page 2, the fact that it is the first post of page 2 is actually just a coincidence.
    If you publish a new post now or change the number of posts per page, it won’t remain first on second page.

    I hope this helps clearing things up!

    Okay, thank you so far.
    That definitely cleared things up, concerning why all that sticky post stuff appears.

    But what could be a recipe, to change that behaviour?

    Does the sticky post has the sticky property at any time? Or is this property only set for the first page (is_home()) and not in that chronological appearance?

    Thanks in advance.
    Regards, Ronelld.

    Theme Author Mathieu Sarrasin

    (@iceable)

    As explained in the codex (see the link and quote from my previous reply), the “sticky” class, which allows for sticky styling is only applied on the first page of the blog index. Everywhere else the post is treated just like any other normal post.

    Changing the behavior may be possible, and how to do it mainly depends on what results you are aiming at. In any case, since this is a core WordPress functionality, altering this behavior would be more of a plugin’s job than a theme’s.

    The theme does not affect functionality, it only provides a bit of CSS styling for the “sticky” class.

    Hey there,
    you are completely right that it might not be a theme’s task. But there is something that confuses me: The second appearance is not only an excerpt, as it is for normal post. It is the complete post. I have the if stuff where I catch the is_sticky () property. And the “Full content” thing of the theme.

    I’ll have a look on the source later. But thank you so far.
    Regards, Ronelld.

    Theme Author Mathieu Sarrasin

    (@iceable)

    Indeed, nice catch !

    Actually WordPress applies the “sticky” class for styling only on the first page, but the is_sticky() function returns true for this post in all circumstance.

    This conditional in index.php is meant to show the full content of sticky post on the first page (where it is given the sticky class), but this also applies on the other pages which wasn’t intended.

    A correct fix would be to replace the ( is_sticky () ) conditional test in index.php with ( is_sticky() && is_home() && is_paged() ) to be more consistant.
    I’ll look at it more closely to confirm and will make this correction in the next update.

    Hey. Thanks for clearance.
    Another option for me, since I’m using a child theme, would have been to duplicate the index.php as home.php and only apply the is_sticky conditional for the home.php.

    I’ll have a look on that being back home.

    Regards, Ronelld.

    Hey again,
    finally I could fix the problem. The suggestion you made was not completely correct (in my opinion).

    I think it should be:

    if ( get_post_format() || post_password_required() || "Full content" == boldr_get_option('blog_index_shows') || ( is_sticky() && is_home() && !is_paged() ) == True ):
    	the_content();
    else:
    	the_excerpt();
    endif;

    And I added a part to filter out the sticky post from the normal blog page in the loop. Eventually it’s not the best coding style.

    if(have_posts()):
    	while(have_posts()) : the_post();
    		?><div id="post-<?php the_ID(); ?>" <?php post_class(); ?>><?php
    
    		if ( ( is_sticky() && is_paged() ) == False ):

    ?></div><br class="clear" /><?php
    		endif;

    So, at least it works for me so far. Thanks for your help.
    Kind Regards, Ronelld.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Sticky Post on all pages’ is closed to new replies.