Support » Plugin: Ultimate Post List » Sticky post not showing at top of list

  • Resolved kjm44

    (@kjm44)


    I’m using Ultimate Post List Pro and I’ve just tried to use it to keep a sticky post at the top for the first time. It is not working. How do I fix it?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Kybernetik Services

    (@kybernetikservices)

    Hello @kjm44.

    Unfortunately it is not allowed to give support for a Premium version here.
    But, because this is also a feature of the free version I think it is ok to answer here:
    Please navigate in your WordPress backend to Ultimate Post List > All Lists > Select the list. In the section List Options, under List Title Options please tick Show sticky posts on top of the list. Save the List.
    Navigate to the blog you want to stick on the top of the list. On the right you need to tick the checkbox Stick to the top of the blog. Save your post.
    The list will show the sticky post on the top of your list, now.

    For further dedicated request for Pro features please use our contact form. Thank you!

    Hope tah helps.

    Thread Starter kjm44

    (@kjm44)

    Thank you, but I had already done both of those steps and it is not working. The sticky post is still showing up after another one that has a more recent date and is not sticky.

    Plugin Author Kybernetik Services

    (@kybernetikservices)

    @kjm44 In this case I assume you don’t use this feature on the front page.
    Unfortunately WordPress does allow sticky post only on the front page. On other pages, WordPress does not take this setting into account.
    So, Ultimate Post List can not show sticky post at the top of the list if the list is not on the front page.
    I will improve the description so, it is more clear how to use it.
    I’m sorry I can not help you with this.

    Plugin Author Kybernetik Services

    (@kybernetikservices)

    @kjm44 because you didn’t reply anymore I assume you could find a solution for your needs. So, I will mark this request as resolved.

    Thread Starter kjm44

    (@kjm44)

    No, I had not seen your answer. That seems very strange. I certainly did not realise a sticky post had to be on the front page.

    Definitely worth improving your description to make it more obvious.

    Is there anyone I can contact to ask about changing the way wordpress handles sticky posts?

    Thread Starter kjm44

    (@kjm44)

    And are you sure you can’t make ultimate post list display a sticky post at the top? It must be an accessible property of a post that you can detect.

    Plugin Author Kybernetik Services

    (@kybernetikservices)

    Hi @kjm44.
    I come back to you after deeper investigation. I can confirm now, sticky post is working also on other than the front page (there has to be a change in the past in WordPress, I think).

    What I did is, I created a post list and ticked the option Show sticky posts on top of the list.
    Then I created a new page and added the shortcodes as well as I added the list in the footer with the Ultimate Post List widget.
    After that I created some posts with different publishing dates. For two post I ticked the option Stick to the top of the blog.
    Then I used a private browser and opened the website. The page as well as the widget in the footer show me both sticky posts at the top. Independent of the sort order I use for the list.

    According to this result I assume another plugin or your theme hook into the sticky post feature from WordPress. Best way is to disable one by one other plugins and check the list.

    If you have further problems, I do recommand to contact us by our contact form for Pro support and we will have a look at your WordPress installation. Please provide your license key in your message.

    Otherwise I would be happy to get your short reply here to know, if you could find a solution.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.