Support » Plugin: Sticky Header Effects for Elementor » Sticky Offset Bug

  • Resolved cuconcepts

    (@cuconcepts)


    Hello there,

    i got a problem.

    When i use the sticky effect for two pictures underneath each other and the offset is set to 0 then everything is fine and it works smoothly. (But the picture is set to the top of the page, because of the offset is set to 0)

    When I set the offset to e.g. 100 (something bigger then 1) the second image starts to jump to the bottom.
    The jumping distance has the same size as picture 1. So i think there is some strange setting causing an error for sticky effects with offset larger than 1.

    Hope somebody can help me out.

    Thx Anton

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Robert Wattner

    (@rwattner)

    Hi, sorry you are having trouble. Do you have a link?

    Hi Robert,

    here is the link.
    It only works when sticky – offset is set to 0.
    When offset is bigger then 0 the sticky middle picture will start to jump down.

    It somehow thinks the upper picture is some element which will be added to the distance. So i think there is some code bug. (Example shows working sticky with 0 offset)

    KR
    Anton

    Plugin Author Robert Wattner

    (@rwattner)

    There isn’t a link on your last post

    Oh man. Sorry for that.
    https://www.cucase.de/?page_id=2867

    it does not stick together but It should overlay together.

    Settings are: sticky: top offset 150 on each picture.

    But somehow picture numbr 2 adds the width of picture number 1 to that offset when scrolling down.
    that is my opinion.

    kr
    anton

    • This reply was modified 2 months, 1 week ago by cuconcepts.
    • This reply was modified 2 months, 1 week ago by cuconcepts.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.