WordPress.org

Forums

Hueman
[resolved] Sticky nav bar (14 posts)

  1. Craftulate
    Member
    Posted 1 year ago #

    Is it possible to make the nav bar sticky with this theme? I've tried a plugin but that doesn't work with my menu subcategories.

  2. Alexander Agnarson
    Member
    Theme Author

    Posted 1 year ago #

    The Topbar menu is stickied by default, as long as the screen resolution is wider than 1024px.

  3. Craftulate
    Member
    Posted 1 year ago #

    Thank you but my screen resolution is 1440 x 900 and the navbar isn't sticky.
    http://www.craftulate.com

  4. Craftulate
    Member
    Posted 1 year ago #

    Argh sorry, just seen you said 1024 *wide*. Ignore my last.

  5. Alexander Agnarson
    Member
    Theme Author

    Posted 1 year ago #

    Actually, your screen is 1440px wide then - however, you use the header navigation area, not topbar. If you change from Header to Topbar, it will be in a fixed position :-)

  6. Craftulate
    Member
    Posted 1 year ago #

    Thanks, I moved it, and that worked!

  7. shreyasr
    Member
    Posted 1 year ago #

    Hi,
    is it possible to make the header/topbar sticky even with lower resolution?

  8. Fuzail Khan
    Member
    Posted 11 months ago #

    Hi, I also have a same problem its not sticky...

  9. Craftulate
    Member
    Posted 6 months ago #

    Since resolving this issue before I have changed to a child theme and my topbar is no longer sticky. Any ideas how I can fix this? Thanks!
    http://craftulate.com/

  10. bdbrown
    Member
    Posted 6 months ago #

    @Craftulate - maybe there's a conflict with your message bar? Also, for some reason your css appears to be missing the following:

    .full-width #nav-topbar.nav-container {
    position: fixed;
    top: 0;
    left: 0;
    right: 0;
    width: 100%;
    z-index: 999;
    }
  11. Craftulate
    Member
    Posted 6 months ago #

    Thanks bdbrown - so I add this code into the style.css of my child theme?

  12. bdbrown
    Member
    Posted 6 months ago #

    That code is already part of the parent style.css file. It's invoked if the screen size is greater than 1025px, which yours is. Next thing I'd check is Theme Options - Styling and make sure Boxed Layout is turned OFF.

  13. Craftulate
    Member
    Posted 6 months ago #

    YES - that was the solution! Thank you! Of course my message bar now covers it, but that's a completely separate issue! ;-)

  14. bdbrown
    Member
    Posted 6 months ago #

    You're welcome. Glad it's fixed.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.