Support » Plugin: EWWW Image Optimizer » Step-by-step instructional to get full functionality, written for a 6yr old?

  • Resolved KrisBunda3D

    (@bunda3d)


    I have zero conceptualization ability of how you’ve got over 100K installs with so much unsupported technical tasks left to the end user. Can we at least call a file a file instead of a “binary” in your brief paragraph of a tutorial?

    I watched both of the videos, and they don’t address the missing files, except for installing that one, which worked nicely in your video, but not for me.

    Can you point to some instructional that explains, step by step, like I’m a 6 yr old, how to move the “missing” files from one place to another, because when I thought I was following instructions, it didn’t work.

    I use Godaddy, PHP 5.3, shared hosting, up-to-date WP install. Then using Windows 7 Windows Explorer as a FTP app, I moved 3 files from the plugin folder w/ “-linux” suffixes to my desktop, renamed them to cut off the “-linux”, and pasted them in the wp-content/ewww/ folder. The files are still “missing”.

    Do you have better/much more complete instructions?

    https://wordpress.org/plugins/ewww-image-optimizer/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    Calling a “binary” a “file” would be like calling a lion an animal. It is accurate, but if you say “there is an animal coming,” I don’t know that I need to run or take shelter…

    Enough with the semantics though (and we’ll get to why ‘binary’ is important in a minute). The plugin normally attempts to install them automatically, and for most users, this “just works”. I’ve tested it myself on Godaddy with PHP 5.3, so I’m a bit surprised you’re having trouble with that, unless there are other errors.

    At any rate, they are called binaries, because they are machine-readable binary files (executables in the Windows world). As such, they MUST be transferred in BIN (binary) mode if you’re using FTP. I do not know if Windows Explorer will do such a thing, but there are plenty of good free FTP clients out there. Try Filezilla for starters.

    If that still doesn’t work, please turn on the debugging option on the EWWW settings page, and then copy and paste the debugging output from the bottom of the settings page via pastebin.com

    I keep trying to use filezilla with my account. It works in SSH mode, but then all I see is a bunch of system files that I assume are usually hidden. I cannot find my content. Just regular ftp (“normal” “insecure”) will not connect. I would say perhaps I’m using an incorrect setting, but I’m doing it how GoDaddy’s tutorials say I should.

    What’s an address I can email you my debug log, so it’s not listed publicly?

    I have some screenshots to show you, http://postimg.org/image/t6fisu3b1/

    Also, since last night when I posted this, I’ve tried:
    upgrading to PHP 5.4, because of something I read on another thread regarding missing mime content type. It didn’t help.

    I’ve tried uninstallig and reinstalling 3 times (incl. deleting the wp-content file if it wasn’t deleted already before reinstalling).

    I made sure my “SSH” privelege was setup, as it was disabled before. I thought this would maybe allow the “exec()” privelege to be enabled. I’m not sure if was responsible for this or not, but now I show on your plugin as having exec() enabled, whereas last night I’m pretty sure I did not, so I suppose that’s progress.

    I’ve checked the folders’ permissions using windows explorer’s ftp client (shown in screenshots image). I assume the permissions are as they should be.

    I’ve tried again a few times to transfer the files w/ the suffixes removed after renaming, but to no avail.

    Here’s what the plugin status message says currently:

    jpegtran: Installed version: Emulating The Independent JPEG Group’s libjpeg, version 6b 27-Mar-1998
    optipng: Missing
    gifsicle: Missing
    pngout: Missing Install automatically | manually – Pngout is free closed-source software that can produce drastically reduced filesizes for PNGs, but can be very time consuming to process images
    safe mode: Off  exec(): Enabled  
    Graphics libraries – only need one, used for conversion, not optimization
    GD: Installed  Imagemagick ‘convert’: Installed
    Only need one of these:
    finfo: Missing  getimagesize(): Installed  mime_content_type(): Missing
    file command not found on your system
    nice command not found on your system (not required)

    Plugin Author nosilver4u

    (@nosilver4u)

    There should not be any sensitive information in the debug info, but if you like, you can send it via https://ewww.io/contact-us/

    I recommend posting it via pastebin.com for better readability if you decide to link it here in the forums instead.

    I sent you the debug report via your email contact form.

    Plugin Author nosilver4u

    (@nosilver4u)

    I should have caught this earlier, but when I was reviewing the debug log again this morning, I realized it is failing to verify the file type of the binaries because finfo AND mime_content_type() are both missing. Can you check your php config on GoDaddy to see if there is a way to enable the ‘fileinfo’ extension?

    Hi, I’m still working on this, just wanted to update.

    Spent time trying to figure it out myself on Google, but finding documentation spotty on some of these things. I’ll just have to call Godaddy tonight, they’re usually pretty helpful. Will be in touch soon.

    I called Godaddy. Apparently I didn’t have a php5.ini file at my web root.

    Here’s what was written in the file:

    ‘<?php
    $finfo = new finfo(FILEINFO_MIME, “/usr/share/misc/magic”); // return mime type ala mimetype extension

    /* get mime-type for a specific file */
    $filename = “/usr/local/something.txt”;
    echo $finfo->file($filename);

    ?>’

    First of all, is that good code?
    2nd, it didn’t do anything to fix the problem. I even uninstalled and reinstalled.

    But I also see this warning on the plugin screen:

    Warning: implode() [function.implode]: Invalid arguments passed in /home/content/XX/XXXXXX/html/blog/wp-content/plugins/ewww-image-optimizer/common.php on line 3098

    (I added the Xs)

    Does this help?

    Plugin Author nosilver4u

    (@nosilver4u)

    It’s slightly helpful, in that we now know you can put a custom php.ini in your web root, but that is not a valid php.ini file at all.

    The code that you pasted is sample code for USING fileinfo, not for LOADING it. If you like, I can take a look at your cpanel if you want to send me the login details at https://ewww.io/contact-us/

    Otherwise, you’ll need to contact godaddy again for information on how to generate a valid php.ini for your webroot, and enable the fileinfo extension. They also have some information on using a .user.info file, and I think you could just insert this in there:

    extension=fileinfo.so

    Yeah, I thought the “something.text” was an eyebrow raiser, but apparently the guy at Godaddy thought it was good stuff… (worried face)

    I’ll call them again tonight and go over it again.

    BTW, you know how html5 has a boilerplate htaccess file? Is there a good boiler plate php5.ini file that I could put on my server that should cover the bases?

    Plugin Author nosilver4u

    (@nosilver4u)

    There is this: https://github.com/php/php-src/blob/master/php.ini-production

    But godaddy might have one that is better suited to their machines. I know with Bluehost, there is a setting on their cpanel that lets you choose the type (and version) of PHP, along with various modules, and that autogenerates a php.ini. I would think GoDaddy would have something similar.

    I think I’m starting to give up.

    I’ve tried various .htaccess and php.ini boilerplate copy/paste settings, I’ve been on the phone w/ godaddy a few times, I tried to install PEAR and it hangs halfway through (thought it would be a way to get extensions enabled).

    Godaddy says I should move from my current “old” hosting plan to one with c-panel. This would involve moving my site and setting everything up again. Sounds like a hassle.

    Plugin Author nosilver4u

    (@nosilver4u)

    You definitely don’t need to use PEAR, fileinfo is already built into php 5.4, it just needs enabled.

    So from what I’ve been reading on Godaddy’s support site, there are a few tricks to getting a custom php.ini file to work. Since you seem to be on a non-cpanel account, that helps narrow things down a bit.

    Their docs say that non-cpanel linux hosting accounts need to use a file named php5.ini (note the ‘5’). I would use the production php.ini file I linked earlier, and just add the ‘extension=fileinfo.so’ line at the end.

    The next trick is that it will likely not take affect right away, you have to kill the php/web process and then visit your page again to restart it using these instructions: https://support.godaddy.com/help/article/5980/managing-system-processes-on-linux-hosting-accounts

    A way to see if your php5.ini file is even being read is by creating an info.php file in your webroot and loading it in your web browser. The info.php only needs one line:

    <?php phpinfo(); ?>

    If you’re not sure what to look for on there, shoot the link to the info.php file to me via https://ewww.io/contact-us/ and I’ll take a look at it.

    If not of that works, you can always use the EWWW IO Cloud API. It isn’t free, but the lossy compression is well worth the money.

    finally got things working after deleting the .htaccess file at my webroot. Not sure what was in there, but it wasn’t screwing up just the plugin, but my phpinfo thought I had a prev. vsn of PHP installed than what I should’ve been using.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Step-by-step instructional to get full functionality, written for a 6yr old?’ is closed to new replies.