Support » Installing WordPress » Step 4 question, probably dumb

  • I want my blog to “live” at blog.mydomain.com (which points to a subdirectory blog of mydomain.com, i.e., http://www.mydomain.com/blog in my file system).

    But I want the home page of http://www.mydomain.com to be a Page I create using WordPress.

    Sooooo I’m trying to answer the first question of step 4, decide where you’d like your blog to appear. I think it’s the second choice, a subdirectory. Or is it? Does the Page at root count?

    I don’t want to clutter up my public_html directory so I’m leaning toward a subdirectory. Can I assume that will still allow me to put my Page at http://www.mydomain.com (a higher directory)?

Viewing 7 replies - 1 through 7 (of 7 total)
  • OK well here’s my problem, part deux. I went ahead put wordpress in the folder mydomain.com/blog. And it is indeed visible when I type in blog.mydomain.com. However, as soon as I went to view the one comment that was there, it went to the longer URL:

    http://www.mydomain.com/blog/?p=1#comments.

    That kind of defeats the purpose of my setting up the blog.mydomain.com subdomain. I would really like ALL the pages to show as blog.mydomain.com/blahblahblah … so is this an .htaccess issue or a wordpress issue or … something else?

    Make sure you have a blank .htaccess file in wordpress root, chmod it to 777, then access wp-admin/options/permalinks tab, select the style you want, wp will write to the .htaccess file, then chmod permissions on the .htacces back to 644.

    Explanation here: Using_Permalinks

    OK great, I just went into the Options/General Options and changed both the WordPress address and the blog address to the subdomain and it appears to be doing what I wanted it to. I don’t see an .htaccess file in my /blog directory and I didn’t need to chmod anything so I don’t know how it made the change, but whatever. I guess I’ll read through that Using Permalinks page and make sure I’m on the right track. Thanks.

    Well, what you did really doesn’t affect the way your post links will appear in the address bar/to search engines. For that, you need permalinks.

    There isn’t an .htaccess file by default. To get one, you’ll have to save a blank file (in Notepad – NOT word or wordpad!) as htaccess.txt, upload it to wp root, then change the filename on-server to .htaccess (you can’t save a file as .htaccess on your local machine, why I’m giving you what looks like a “runaround”….). Then you’ll need to change the permissions as I stated above.

    Can I just create it in vi? As in vi .htaccess when I’m in my /blog directory?

    Thanks for following up … I saw that permalink page and my head wanted to explode. But I guess I can’t get around it.

    What’s “vi”? Is it like a text editor? If it will allow you to save a file as .htaccess, sure. Otherwise, you’ll have to use the dink workaround as above.

    Yep, vi “the-one-true-editor” would work just fine.

    Geeked,

    Handy

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Step 4 question, probably dumb’ is closed to new replies.