WordPress.org

Support

Support » Installation » Step 3 — upgrade_072

Step 3 — upgrade_072

  • Hey, so I have a tricky situation… I’m running php5, apache2, and mysql 4.1 on RH Fedora 1. I’ve fixed the mysql calls so that they work with php5 and mysql4.1 (mysqli), but whenever I do install, it gets stuck in upgrade_072. I can’t really downgrade mysql (because my thesis is running off of it), and I don’t know if this is a problem with php or upgrade-functions. I also made the maybe_create_table more clean by removing all the code from if and changing the queries to be CREATE TABLE IF NOT EXISTS… don’t think it should break anything… anyhow… when I run upgrade.php to with step=1, I get the following dump:
    SQL/DB Error:
    [<span style=’color: #007;’>Duplicate entry ‘1-0-siteurl’ for key 1</span>]
    INSERT INTO wp_options (option_id, option_name, option_type, option_value, option_description, option_admin_level, option_width) VALUES (1,'siteurl', 3, 'http://smokejumper.princeton.edu', 'siteurl is your blog\'s URL: for example, \'http://example.com/wordpress\'', 8, 30)
    </div>Segmentation fault
    Thanks

Viewing 1 replies (of 1 total)
  • Well, I after a lot of hacking I got around the error. The problem, I feel, is more in php5 than anything else. Anyhow, if anyone is looking for a workaround in PHP 5, I’ve kinda got one.

Viewing 1 replies (of 1 total)
  • The topic ‘Step 3 — upgrade_072’ is closed to new replies.
Skip to toolbar