Support » Fixing WordPress » Step 2 – a bunch of database errors

  • Resolved MatthiasBekaert1

    (@matthiasbekaert1)


    I’ve got a lot of this errors.

    [Unknown character set: 'utf8_unicode_ci']
    [Table 'wordpress.wp_options' doesn't exist]

    They all have different descriptions. I don’t know how I have to solve this.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Can you supply us with more information?

    What are you doing when you receive those errors?

    If installing WordPress, did you edit the wp-config.php by hand?

    The line below should work, what does this say in your wp-config.php?
    define('DB_CHARSET', 'utf8');

    I edit it by hand indeed, but ‘utf8’ didn’t work. With ‘utf8’ it loaded, but then it stays at step2 with a white screen.

    So I tried to set charset to (utf8_unicode_ci) and then I could start with the installation, but after the first step, it gave this errors. They look like this.

    I changed it just again to utf8, and it worked, thanks!!

    Have you tried adding the line below to your wp-config.php?

    define( 'WP_DEBUG', true );

    I’d change the charset back to utf8 and see if you receive any errors.

    (this is a new clean install, not a migration?)

    Super!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Step 2 – a bunch of database errors’ is closed to new replies.