WordPress.org

Support

Support » Installation » step 1 of the install

step 1 of the install

  • Every time I run the installer it fails to be able to create wp_linkcategories. It can make wp_links though, right afterwards.
    Is this going to be a problem? I’m getting tired of blowing away the database and starting over (doing this all via command line is a pain, I barely know mysql.
    Can’t find table ‘wp_linkcategories’, gonna create it…
    Can’t create the table ‘wp_linkcategories’ in the database.
    CREATE TABLE wp_linkcategories ( cat_id int(11) NOT NULL auto_increment, cat_name tinytext NOT NULL, auto_toggle enum (‘Y’,’N’) NOT NULL default ‘N’, show_images enum (‘Y’,’N’) NOT NULL default ‘Y’, show_description enum (‘Y’,’N’) NOT NULL default ‘Y’, show_rating enum (‘Y’,’N’) NOT NULL default ‘Y’, show_updated enum (‘Y’,’N’) NOT NULL default ‘Y’, sort_order varchar(64) NOT NULL default ‘name’, sort_desc enum(‘Y’,’N’) NOT NULL default ‘N’, text_before_link varchar(128) not null default ‘
    ‘, text_after_link varchar(128) not null default ‘
    ‘, text_after_all varchar(128) not null default ‘
    ‘, list_limit int not null default -1, PRIMARY KEY (cat_id) )
    You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘-1, PRIMARY KEY (cat_id) )’ at line 1
    any suggestions?
    -thomas

Viewing 3 replies - 1 through 3 (of 3 total)
  • Sometimes WordPress gives error messages even when everything is fine. Have you checked to see whether link categories are actually there?

    It isn’t normally a problem since most of us probably don’t have this problem (I know I don’t). When I first installed WP 1.01 I ran into errors, but I just ignored them and it ran just fine. When I installed 1.02, and sequentially nightly 04/19/04, 04/23/04, etc. and up to WP 1.2 Beta, I had no problems at all, but the database already existed. When I installed 04/19/04 nightly on a different database it had no problems.
    What version are you using?

    I am experiecing the same issues. I ran SHOW TABLES from myql prompt and it returned “Empty set (0.00 sec)” Can you offer any advice?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘step 1 of the install’ is closed to new replies.
Skip to toolbar