Support » Fixing WordPress » Staying logged in to WordPress

Viewing 4 replies - 1 through 4 (of 4 total)
  • It looks like you have some mixed content issues where some of your pages are https and others are http. I’m wondering how that effects things and I’m wondering why it’s doing that.

    So read up on it here https://www.wpbeginner.com/plugins/how-to-fix-the-mixed-content-error-in-wordpress-step-by-step/ and maybe try the recommended plugin to see if the problem goes away.

    Hey, that is extremely helpful thanks, I knew nothing about that before. But it makes sense, because my new host enables SSL and so my website is supposedly all now https.

    So I read the article you linked, installed and activated the plugin, but so far no change.

    Would you say that the host should know about this and be able to fix the SSL, or is it my problem to fix WordPress?

    Thanks

    when changing a wordpress install to SSL, a common problem is that there are still http – urls hardcoded in the database or in the template files. this might cause it.

    also check your home url setting.
    maybe it helps to put

    define( 'WP_SITEURL', 'https://example.com/wordpress' );
    define( 'WP_HOME', 'https://example.com/wordpress' );

    into wp-config.php.

    • This reply was modified 1 year, 4 months ago by danthefan.

    Thanks guys for your help, it set me in the right direction.

    I ended up asking my host for support, and they found that my database was full of links with http:// addresses that were not mixing well with the https:// address that WordPress was now generating. Which is just as you guys said.

    They were kind enough to do a search and replace in my database and that changed 12,000 occurrences!

    I had hard-coded all those links by cutting and pasting from the address bar. I guess there must be a better way, to get WordPress to make the link and then it would have changed automatically (I guess). Something more I’ll have to read up and learn about!

    Thanks again.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Staying logged in to WordPress’ is closed to new replies.