Support » Plugin: Redis Object Cache » Status: Not Connected (Digital Ocean, Ubuntu 18.04)

  • Even after correct wp-config definitions and confirming 127.0.0.1:6379 ping works, I am still getting a “Connection Refused”.

    Not sure what else to do but I’ve been trying different configs for the last hour.

    Diagnostics below.

    Status: Not Connected
    Client: PhpRedis (v4.3.0)
    Drop-in: Valid
    Connection Exception: Connection refused (RedisException)
    Redis Extension: 4.3.0
    Predis Client: 1.1.1
    PHP Version: 7.2.17
    Multisite: No
    Global Prefix: "wp_"
    Blog Prefix: "wp_"
    WP_REDIS_SCHEME: "tcp"
    WP_REDIS_HOST: "127.0.0.1"
    WP_REDIS_PORT: "6379"
    WP_CACHE_KEY_SALT: "www.website.com"
    WP_REDIS_PASSWORD: "***************"
    Global Groups: [
        "blog-details",
        "blog-id-cache",
        "blog-lookup",
        "global-posts",
        "networks",
        "rss",
        "sites",
        "site-details",
        "site-lookup",
        "site-options",
        "site-transient",
        "users",
        "useremail",
        "userlogins",
        "usermeta",
        "user_meta",
        "userslugs"
    ]
    Ignored Groups: [
        "counts",
        "plugins",
        "blog-details",
        "blog-id-cache",
        "blog-lookup",
        "global-posts",
        "networks",
        "rss",
        "sites",
        "site-details",
        "site-lookup",
        "site-options",
        "site-transient",
        "users",
        "useremail",
        "userlogins",
        "usermeta",
        "user_meta",
        "userslugs",
        "blog_meta",
        "themes"
    ]
    Dropins: 
     - advanced-cache.php v by 
     - db.php v by 
     - Redis Object Cache Drop-In v1.4.3 by Till Krüss
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    When SSH’d into that exact machine, does redis-cli work?

    Yes I got the ping/pong test success via SSH redis-cli.

    Is there any other output data I can show you to help?

    Could you try switching to Predis, see if that works?

    Same thing – connection refused.

    Status: Not Connected
    Client: Predis
    Drop-in: Valid
    Connection Exception: Connection refused [tcp://127.0.0.1:6379] (Predis\Connection\ConnectionException)
    Redis Extension: 4.3.0
    Predis Client: 1.1.1
    PHP Version: 7.2.17
    Multisite: No
    Global Prefix: "wp_"
    Blog Prefix: "wp_"
    WP_REDIS_CLIENT: "predis"
    WP_REDIS_SCHEME: "tcp"
    WP_REDIS_HOST: "127.0.0.1"
    WP_REDIS_PORT: "6379"
    WP_CACHE_KEY_SALT: "www.website.com"
    WP_REDIS_PASSWORD: "***************"
    Global Groups: [
        "blog-details",
        "blog-id-cache",
        "blog-lookup",
        "global-posts",
        "networks",
        "rss",
        "sites",
        "site-details",
        "site-lookup",
        "site-options",
        "site-transient",
        "users",
        "useremail",
        "userlogins",
        "usermeta",
        "user_meta",
        "userslugs"
    ]
    Ignored Groups: [
        "counts",
        "plugins",
        "blog-details",
        "blog-id-cache",
        "blog-lookup",
        "global-posts",
        "networks",
        "rss",
        "sites",
        "site-details",
        "site-lookup",
        "site-options",
        "site-transient",
        "users",
        "useremail",
        "userlogins",
        "usermeta",
        "user_meta",
        "userslugs",
        "blog_meta",
        "themes"
    ]
    Dropins: 
     - advanced-cache.php v by 
     - db.php v by 
     - Redis Object Cache Drop-In v1.4.3 by Till Krüss

    It might be your Redis config, I’m not sure. I’d suggest to hire a qualified developer to help you with this.

    The redis config is default..

    Can I message you?

    I’m the wrong guy to help you with this. I use Heroku’s managed Redis instances.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.