Support » Plugin: Slimstat Analytics » Stats Not Working?

  • Resolved pawdl

    (@pawdl)


    My server logs show visits to my website, but Slimstat doesn’t seem to be logging them since the last update (v.4.7.9.1). I haven’t changed any Slimstat filters and I normally see Google bots in the dashboard’s “Visitor Activity” section. Now, Slimstat hasn’t shown any new activity since about 4/22. I suspect that is when I updated either the last time or the time before, but not sure. There were two updates close together and I may have been hoping that the most recent update would fix the lack of logging by Slimstats.

    I am running WooCommerce 3.6.2., PHP version: 7.2.7. Am I missing something? Am I the only one?

    Thank you…

    • This topic was modified 9 months ago by pawdl.
    • This topic was modified 9 months ago by pawdl.
Viewing 15 replies - 16 through 30 (of 36 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    @mattthev are you already testing the latest 4.8? Could you please uninstall and reinstall the Browscap data file (Settings – Maintenance)

    Thanks

    mattthev

    (@mattthev)

    No, I didn’t. I was waiting for the support e-mail what version to test.
    I’ve installed it also new Bowscap and it is still the same. Every visitor seems to be counted as bot [04-29-19 05:08 pm] 310 Bot not tracked The message here above will indicate if a page view was not recorded because it matched at least one of the conditions you configured in your settings (filters, blackslists, etc).
    I don’t use any filters, everything use default settings.

    Plugin Author Jason Crouse

    (@coolmann)

    Please click the little X icon next to the error message, and see if it comes back. Slimstat doesn’t reset that message. Also, could you send me a screenshot of the Activity Log by replying to the ticket you opened? If a page view is tagged as “bot”, then it should have a little spider icon next to it in the Access Log.

    Jason

    mattthev

    (@mattthev)

    The spider is there only if I switch to server from client and disable caching. When it is on client it only shows this msg “310 Bot not tracked” in maintenance and it updates, I tried it every minute with different browser and always just this msg and a minute later or when I use Firefox, there is something with Prefetch.

    Plugin Author Jason Crouse

    (@coolmann)

    @mattthev could you send me a screenshot of both the Activity Log and the Maintenance tab so that I can take a look?

    mattthev

    (@mattthev)

    Sure, sent in the support ticket.

    Plugin Author Jason Crouse

    (@coolmann)

    Please deactivate all your cache plugins if you’re using “Server” mode.

    Plugin Author Jason Crouse

    (@coolmann)

    @pawdl can I close this ticket?
    @mattthev keep me posted on your tests!

    pawdl

    (@pawdl)

    I haven’t had time to check any further. The stats seems to work only when Tracking Mode is is set to Server. I am not using a caching plugin, so it seems this option should be set to Server, but it was set to Client and stats seemed to have worked then. Which way should it be?

    Plugin Author Jason Crouse

    (@coolmann)

    @pawdl did you turn the CDN option off, if you’re testing version 4.8? That might be the reason why Client mode is not working.

    pawdl

    (@pawdl)

    I am running v.4.7.9.1 and have tried running in client mode with CDN on and off. No stats.

    felixt80

    (@felixt80)

    Hello, same problem here. Installed latest version of the plugin some days ago and no more logs: seems that everyone is marked as a bot.
    Steps to reproduce:
    1) disable all plugins except slimstat
    2) go in slimstat settings and clear the “tracker notice”
    3) open a Chrome incognito window and open the website
    4) refresh the settings page: a new bot tracker notice appears, no logs

    Solved by uninstalling browscap library (and not reinstalling again).
    Thanks!

    Plugin Author Jason Crouse

    (@coolmann)

    It would be great if you could test version 4.8.

    Jason

    How do I get 4.8? When I go to https://support.wp-slimstat.com/, I get a 403 Forbidden.

    Plugin Author Jason Crouse

    (@coolmann)

    Yes, I’m working with our hosting provider to fix that problem. In the meanwhile, you can go to our Github repository and download it from there:

    https://github.com/slimstat/wp-slimstat/archive/master.zip

    Unzip the file and upload its content to your server under

    /wp-content/plugins/wp-slimstat/

    Thank you,
    Jason

Viewing 15 replies - 16 through 30 (of 36 total)
  • The topic ‘Stats Not Working?’ is closed to new replies.