Support » Plugin: WP Statistics » Statistics are drammaticly wrong

  • Resolved illatooscuro

    (@illatooscuro)


    in the FAQ you say:
    I was using V3.2 and now that I’ve upgraded my visitors and visits have gone way down?
    The webcrawler detection code has been fixed and will now exclude them from your stats, don’t worry, it now reflects a more accurate view of actual visitors to your site.

    I’m checking my site with google analytics.. i see for today
    524 unique visitors .. 588 visits.. on the wp statistic i see 44/64

    i’ve tested with mobile and asked a friend to visit my site.. i checked it online with analytics but refreshing WP gives always the same result… after like 30/40 more visits (they was not bot btw) i’ve seen a +1 in site statistic. Also the official wordpress statistics are more similare to the google one. There’s something i could check? consider that i’ve enabled/disabled… removed and reinstalled.. the results are the same

    Regards Silvio

    https://wordpress.org/plugins/wp-statistics/

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Contributor Greg Ross

    (@gregross)

    What have you setup for your exclusions?

    The more relevant FAQ is:

    = I’m using another statistics plugin/service and get different numbers for them, why? =

    Pretty much every plugin/service is going to give you different results for visits and vistors, there are several reasons for this:

    * Web crawler detection
    * Detection method (javascript vs server side PHP)
    * Centralized exclusions

    Services that use centralized databases, like Google Analytics, for spam and robot detection have better detection than WP Statistics can. The trade off of course is relaying on an external service.

    Hi Greg,

    i’m just using the default configuration… where i’m excluding the administrators from check and the default robot list.

    there’s a log i could check to see if excludes something? Just an info more.. i’m getting this problem since i trasferred the site from another host. Btw i’ve checked permissions and logs and everythings seems ok.

    Regards

    Plugin Contributor Greg Ross

    (@gregross)

    You can turn on exclusion tracking via Statistics->Settings->Access/Exclusions->Exclusions->Record Exclusions.

    You can then view the exclusions from Statistics->Exclusions.

    Does your new host use caching that your old one didn’t? If they aren’t loading the page but instead serving a cached copy that would not result in a hit being detected by WP Statistics.

    OK enabled.. where i could check the log file to see what exludes?

    the only differences is the os version.. i was on a centos 6.5 and now 7.0.. the machine is configured by me and i made no differences between the two configurations

    ps: if you need an help in translating your plugin in italian let me know 😉 there’s a lot of mistakes.. just ask me 😉

    Plugin Contributor Greg Ross

    (@gregross)

    You’ll see the exclusions show up on the Exclusions page (from the main Statistics menu).

    We always appreciate help with the translations, do you know how to edit .po files?

    hmm.. no.. send me a guide 😉 i’ll do it right now (until kids get bored of playing alone 😀 )

    ok.. done a test.. i’ve opened on another pc the site… i saw on analytics data passing.. i browsed a couple of pages… on Wp statistic no +1 visits and i saw a +1 in exclusion …

    well..now the question is.. why i was excluded? 🙂

    note: i was not logged on the site…

    Plugin Contributor Greg Ross

    (@gregross)

    What was the reason for the exclusion?

    Go to http://poedit.net/ and download poedit. A copy of the Italian language file is included with the plugin in: wp-content\plugins\wp-statistics\languages. The file name for Italian is wp_statistics-it_IT.po.

    Make a copy of the .po file to a temporary location and use poedit to update the strings. Save it and send it to us (you can use the contact form on wp-statistics.com).

    ok.. i start working on translation right now.. a couple of h and will be ready… for the reason plugin is not working.. i gave up 🙂 i really dunno why it is working this way

    yesterday Ganalytics gives me

    473 sessions, 410 users .. 1258 page hits

    Wp Stats gives me

    50 visitors – 67 visits (i saw 219 esclusions…)

    WordPress statistics gives me 833 views + these referrals
    Facebook 249
    Google+ 115
    http://www.illatooscuro.it 47
    Search Engines 41
    http://www.ReteGay.it 22
    http://www.PensieroErotico.it 17
    blogitalia.it/leggi/66025/ 2
    ziczac.it/a/leggi/fcb9a9b2e01cd3adc9c3acdc58fdbaab/ 1

    and as you can see.. are more than 50 visitors 🙂

    if you want i could give you site access to test yourself.. is very strange..

    ok..now working on poedit 😉 c ya later

    Plugin Contributor Greg Ross

    (@gregross)

    I can take a look, send me the login details via the contact form on wp-statistics.com.

    Can you also check your PHP error log?

    Plugin Contributor Greg Ross

    (@gregross)

    Ok, I took a look and the only item I see that could be interfering with the stats is the caching plugin.

    We’ve seen caching plugins interfere with WP Statistics before because they don’t run our code all the time. In comparison, both Google and WordPress use externally hosted code to do the statistics tracking so the caching plugin doesn’t effect them.

    If possible I’d suggest disabling the caching plugin for a day and see if the numbers are closer after that.

    ok disabled.. let’s see what happen 😉

    first of all.. Happy New Year )

    disabling cache plugin did not helped.. but right now i’ve disabled ipv6 (that was giving some problems with postfix) and actually statistics are more and more accurate.. i’m do a daily check tomorrow morning but maybe we’ve found the problem. 😉

    Byzze

    Plugin Contributor Greg Ross

    (@gregross)

    We don’t support IP6 so if the web server was passing them in then it could cause this kind of problem.

    it’s ok .. we can close the thread.. it was ipv6 problem.. now statistics are in line with the expectations 😉

    if you need further translations just send me an email 😉

    Happy New Year and thanks for the support.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Statistics are drammaticly wrong’ is closed to new replies.