WordPress.org

Forums

[resolved] Statistics (23 posts)

  1. Vera
    Member
    Posted 10 years ago #

    Hey, I just installed this wordpress statistics thing for my blog.

    http://vera.pyhra.org/wp/wp-stats.php

    I've noticed that some things line up, not all. I want them all to line up so it looks neat.

    For example, as you can see "10 Recent Posts"
    the alignment for the title of the posts are aligned perfectly while when you see "10 Recent Comments, 10 Most Commented Post, Post Categories Statistics or Top 20 Commenters" the (numbers) or post title are not aligned.

    Is there a way to fix it?
    Any help is greatly appreciated asap. Thanks for your efforts in advance!

  2. Beel
    Member
    Posted 10 years ago #

    You first should get your page close to validating:
    Invalid xhtml

    Hard to get things aligned correctly when you have improperly nested lists and open divs.

  3. Vera
    Member
    Posted 10 years ago #

    I tried fixing some but I couldn't get around to some of the errors specified there. Could anyone give me pointers to start =(? I'm afraid I'll mess things up ever worse O__O'
    Thanks very much!

  4. Vera
    Member
    Posted 10 years ago #

    And also, for the "first error" about this:

    <script language="javascript">
    //<!--
    function plugrules()
    { window.open ("http://vera.pyhra.org/wp/wp-content/themes/elegance/plugit/plugrules.php","popup","width=340,height=334,location=0,menubar=0,resizable=0,scrollbars=0,status=0,titlebar=1,toolbar=0") }
    --></script>

    I tried fixing it by doing so:

    <script language="text/javascript">
    //<!--
    function plugrules()
    { window.open ("http://vera.pyhra.org/wp/wp-content/themes/elegance/plugit/plugrules.php","popup","width=340,height=334,location=0,menubar=0,resizable=0,scrollbars=0,status=0,titlebar=1,toolbar=0") }
    --></script>

    However, I couldn't open the javascript pop-up when I clicked on the link it was suppose to pop up, so if i leave it like

    <script language="javascript">
    instead, it's fine but it wouldn't validate properly =/.

  5. Vera
    Member
    Posted 10 years ago #

    Also, does anyone have any idea where I can find the "categories" file because I'm trying to remove "

  6. " to get rid of something.

    As you can see under the "Classifications" heading on my sidebar. I just placed this code:

    <?php list_cats(0, '', 'name', 'asc', '', 1, 0, 1, 1, 1, 1, 0,'','','','','') ?>

    And I have no idea where I can find the php to that file so I can delete that code I want. Thanks :)

  • Beel
    Member
    Posted 10 years ago #

    <script type="text/javascript" - that will work and validate.

    Don't understand your second question, but I haven't had my coffee yet. As for other validation issues:

    1. ID's, as the initials imply, are supposed to be unique. You can't have more than one ID of "active" - but you can change it to a class.
    2. Put the table "stuff" in the css. If you don't want to do that, then change the "background-color="#D4D5F0;" to style="background-color:#D4D5F0;"
    3. td's need to be wrapped in tr's for a proper table
    4. close out your input tag with a "/>"

    The rest is up to you.

  • Vera
    Member
    Posted 10 years ago #

    The <script type="text/javascript" would work? Hmm, I tried it and it didn't work for me some how.

    Oh alright. Thanks.

    1. I'll try it soon.
    2. I don't really want to add it in the css so I changed it to how you said and the validator still had the same number of errors =S.
    3. <tr> and then <td> as always right?
    4. I tried to close the input tags with "/>" and again, I got the same number of errors.

    Thanks very much :). Do you think I can send you the files and see what you can do for me? =/ maybe it's faster, if you don't mind? Or possibly talk through things on MSN if you have one?

    Thanks again! I really appreciate it!

  • Beel
    Member
    Posted 10 years ago #

    Computer keeps crashing when I post, hopefully the 3rd time will be a charm.

    Am I looking at the same site? (the link you provided above) I ask because there are still multiple id="active", the javascript is not yet set properly, etc.

    You also have a table before the <head> which is an obvious no-no. There is no need to send me the code you have as I can read the source from the validation page. If you still care to post it do it here so that others may help out.

  • Vera
    Member
    Posted 10 years ago #

    Hope your computer is better :).

    I haven't fixed that " id="active" " part yet. I'm trying to fix something, yepp sorry bout that @__@'

    Oh yes, I've noticed *took it out and put it after ending </head> tag.

    Okay. I'll post one over there later. I'll keep you up on the updates though. But could I contact you somewhere or are you okay with the forum?

  • Beel
    Member
    Posted 10 years ago #

    Forum is fine, e-mail is ok, too. There is also a contact form on my website. Just about any way is fine.

    - Beel

  • Vera
    Member
    Posted 10 years ago #

    Okay. I took out the "id=active" thing.

    As for the <td> thing, i have to find all <td> 's and add <tr> 's in front of it eh?

    And i replaced the thing as you said with :
    style="background-color:#$bgcolor;"
    which gave me an error saying I have 2 styles =S you can check it in my validation somewhere.

    And does it appear to you that I've closen all input tags? Or am i going blind? .. I'm going to rest now.. O__O'

  • Beel
    Member
    Posted 10 years ago #

    <table>
    <tr>
    <td></td>
    <td></td>
    </tr>
    <tr>
    <td></td>
    <td></td>
    </tr>
    </table>

    You may have closed all the inputs but the error still shows up as a result of another error that is occuring, such as the style portion of one input tag:
    style='....border: 1px solid '#A8A9BB' /> you have too many apostrophes, remove the bold one.

  • Vera
    Member
    Posted 10 years ago #

    Okay, I think I got the table structure correct =/.

    As for the input thing, I tried it and I got another error O__O'

  • alia
    Member
    Posted 10 years ago #

    if you are a bit familiar with html and css, it is pretty easy to set up a new clean theme by frequenting the Documentary section. I did so and after a few days of pretty interesting new views on modern web design (ok, i cursed myself too sometimes...) i had my own theme set up and running.
    you can turn this:
    http://validator.w3.org/check?uri=http%3A%2F%2Fvera.pyhra.org%2Fwp%2F
    into this:
    http://validator.w3.org/check?uri=http%3A%2F%2Fadablog.solar-afrika.de%2F

    if you like creating your own stuff, you will sure have some fun on that, me too, i do have a zero knowledge about php, but i did it anyway.

  • Beel
    Member
    Posted 10 years ago #

    Don't worry about "another error" - just fix the ones I mentioned and then go down the list, fixing them as you go. This is an opportunity for you to unlearn bad html and learn proper xhtml. FIX the javascript!

  • Vera
    Member
    Posted 10 years ago #

    Yep, I once had my site valid xhtml but then later I added lots of stuff and I got many errors again O__O" lol.. eep. =(

    yepp, i fixed the javascript.. it turns out I read something wrong.. my mistake o^__^o.. hehe, yepp I'm stuck again. Some errors look weird and most of the time I dont' understand what error it is =S or maybe it's just me.

  • Beel
    Member
    Posted 10 years ago #

    line 31 error: table is before the <body> tag and in the <head>
    line 32: same with the div tag
    line 89: you have 2 "style=" in your table tag
    line 94: same as 89
    etc., etc.

    These are all basic errors in html and xhtml
    http://www.w3schools.com/xhtml/default.asp

  • Vera
    Member
    Posted 10 years ago #

    I believe the main part we are discussing is this page:

    http://vera.pyhra.org/wp/wp-content/themes/elegance/plugit/plug.php

    But I can't seem to fix the 5 errors mentioned there.

  • Beel
    Member
    Posted 10 years ago #

    Yeah, you have really buggered up your sidebar. It is part list, part table, part whole new page, part....

    You should probably make it one big list with nested sublists. You cannot have a table in a list and not wrapped in <li>'s. You also cannot have a <head> and <body> within your main <body>.... as with humans, there can only be one head, one body - unless you want a deformed mess.

    At this point it might be best to pull every thing out and add it one piece at a time, keeping it valid as you go. The link I posted above is a good resource for learning html.

  • Vera
    Member
    Posted 10 years ago #

    Yep i know, thanks :). I'll try to figure things out =/ if i can :D!

    I'll e-mail you or continue with this discussion if i run into errors. Thanks alot guys ;)

  • Vera
    Member
    Posted 10 years ago #

    Okay. I got most of it resolved. Wow, I never thought it would take that long. Anyway, I was thinking of putting some data (categories) into a table format like so:

    <table>
    <tr>
    <td>
    CATEGORY THINGS HERE...
    </td>
    </td>
    etc.

    So it would look "neat and tidy" But i'm not sure where I do that, is it within wp-stats.php or somehow in the php code? *confused*

  • Beel
    Member
    Posted 10 years ago #

    Not knowing what you are trying to do or what "category things" you plan on showing makes it a bit difficult but I assume in can go in WP stats in list form just like the stuff displayed already in wp-stats.

    Spent the day fishing in the mountains. Tired, stinky and burnt to a crisp so don't know if I will be around much more tonight.

  • Vera
    Member
    Posted 10 years ago #

    I got it =) thanks - I'll say it's resolved

  • Topic Closed

    This topic has been closed to new replies.

    About this Topic

    Tags

    No tags yet.