Support » How-To and Troubleshooting » Static pages come up as 404

Static pages come up as 404

  • I am having problems with static pages on my site. When ever I make a new one, the page says that it has been created in the backend, and it does come up on the menu. But when I click the link on the menu it comes up as a 404. You can see this on my site, http://www.freedomdown.net/ if you click on “contact” or go to “http://www.freedomdown.net/contact”. If someone could help me with this ASAP I would really appreciate it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • After making each static page, you need to update your .htaccess. Do this under Options->Permalinks.

    I keep clicking update PermaLink Structure but it still gives me a 404.
    FYI I did not have to do any updating of PermaLinks when I created all the other pages.
    This already is in the httaccess file before:
    RewriteRule ^(contact)/feed/(feed|rdf|rss|rss2|atom)/?$ /index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(contact)/(feed|rdf|rss|rss2|atom)/?$ /index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(contact)/page/?([0-9]{1,})/?$ /index.php?pagename=$1&paged=$2 [QSA,L]
    RewriteRule ^(contact)/?([0-9]+)?/?$ /index.php?pagename=$1&page=$2 [QSA,L]
    RewriteRule ^(contact)/trackback/?$ /index.php?pagename=$1&tb=1 [QSA,L]

    nm, I seamed to have fixed it. Thanks.

    I am able to see your contact page fine in IE6.


    As I said, the issue has been resolved.

    Thanks all of you guys.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Static pages come up as 404’ is closed to new replies.