Support » Fixing WordPress » Static page causing blank title

  • Resolved brisrocket

    (@brisrocket)


    I have recently created a static home page in my self-hosted wordpress site, but now have the problem where my title tags are blank (well, contains the blog title but is missing the page/post title).

    I’m using All In One SEO Pack that builds a title tag based on either:
    Post Title Format: %post_title% | %blog_title%
    Page Title Format: %page_title% | %blog_title%

    Q1) Which one of the above actually builds the <title> tag
    Q2) How do I get my “Title” to come through in the <title> data
    Q3) How problematic is this static page approach? I have trawlled through a lot of articles here with people having nightmare problems with this and I am questioning if this is a good idea or not.

    I have rolled this into a high ranking blog http://sfiaaustralia.com.au/ but am thinking I should have trialled this onto my small personal blog first…

Viewing 1 replies (of 1 total)
  • After hours of searching, what do you know… I found the fix just after I posted the call for help.

    For those experiencing the same issue, look at your All In One SEO configuration (Dashboard – Settings – All In One SEO) and then edit the “Home Title” and “Home Description”. These were blank in my configuration and had never been used until I created this home page.

    Hope this helps somebody else having the same problems!

    I was hoping I didn’t have to go editing home.php and other files which were some of the other suggested resolutions that didn’t seem to resolve… Easy is good 🙂

Viewing 1 replies (of 1 total)
  • The topic ‘Static page causing blank title’ is closed to new replies.