Support » Plugin: Polylang » Static homepage does not show with polylang plugin

  • Resolved davidgeerts

    (@davidgeerts)


    After installing the polylang plugin, my static homepage does not show, and instead the blog page is shown.

    I have followed the instructions in section 7 of the getting started guide:
    – Created a static Home page (English) and added two translations (so three languages in total). All other pages have English as language.
    – In Settings -> Reading I chose a static page, and selected the Home page as Front page
    – I changed the URL modifications to “The front page url contains the language code instead of the page name or page id”

    Still the blog page shows in each of the languages. After de-installing the plug-in, the normal homepage shows again, so it has to do with the plug-in somehow.

    I’m using the Vamtam Honeymoon theme, if this helps.

    Is there anything I missed?

    https://wordpress.org/plugins/polylang/

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Chouby

    (@chouby)

    Hi!

    I believe that you did things right. To be sure, you can check with another theme such as Twenty Fifteen.

    It’s however possible that your theme does not use the standard WordPress static front page.

    How do you setup the front page (without Polylang)?
    Your theme advertizes to be compatible with WPML. Maybe you can check it the theme author how it is done and see if it could work with Polylang (for example Polylang can read the wpml-config.xml file).

    Hi,

    Thanks for your response! I tried the Twenty Fifteen theme, and it has the same effect: the static homepage is not shown and the blogpage (which we don’t use) is shown instead.

    Without Polylang the front page is selected on the Reading page of Settings by selecting “A static page (select below)” and then choosing “Home” as Front Page. The homepage shows without any problems then. The theme advertises to use Polylang, so I think it should work.

    I did try several times to create different pages, added different languages, and deleted some pages. I also de-activated and re-activiated the plugin a couple of times. Is it possible that somewhere some leftovers from old pages or old settings are still left? Is it a solution to de-install the plugin, remove some files, and do a re-install of the plugin?

    I’m getting quite desperate as our wedding invitations will be sent out this week and we need the multiple languages soon, and we can’t have the empty blog page showing up when they type in the url.

    Any help is highly appreciated!

    Kind regards,

    David

    Plugin Author Chouby

    (@chouby)

    I am sure that it works with Twenty Fifteen. Could you de-activate all your other plugins in case there is a conflict?

    Could you also check that all your home pages are translations of each others (when you edit one, you should see the title of the others in the languages metabox)?

    Finally, could you provide a link? It may help.

    Hi,

    I de-installed all plug-ins, it has the same effect. Can I share the link directly with you instead of on a public forum?

    Thanks!

    David

    Hi, just wanted to let you know that I solved it by choosing the option “The language is set from content” in the Polylang settings. That did the job.

    Kind regards,

    David

    Hi, I had the same problem and thankfull to find this post.

    However, i had to change a different field in the settings:
    (my version of wordpress is in French)

    I had to check the part were it says:

    “L’adresse de la page d’accueil contient le code de la langue au lieu du nom de la page”
    Exemple : http://lemasdelafontaine.fr/fr/ au lieu de http://lemasdelafontaine.fr/fr/le-mas-de-la-fontaine/

    (translated: “the adress of the home page contains the language code instead of the name page”
    for instance: http://lemasdelafontaine.fr/fr/ instead of http://lemasdelafontaine.fr/fr/le-mas-de-la-fontaine/)

    That dit the trick for me… (i use the Forever Theme, and Polylang had worked fine until lately, something to do with an update maybe?)

    Same problem here, using the Twenty Fifteen theme on http://verb.company.

    I was able to fix it using the advice from Gaelle73 on this thread. Merci beaucoup!

    Please note that I had to deactivate and reactivate Polylang for the setting he indicates to show up.

    I am having the same problem using the theme named “Reception”.
    My website address is: http://www.ilviaggiatoreabruzzo.it
    Tha advice Gaelle73 gave does not work for me, what can I do?

    I have the same problem. Theme from templatemonster theme45715
    site http://taxpro24.pl/

    I have a slightly different problem. My static home page appears with the right header and footer but nothing in between. After selecting home page on the header, the full static home page appears.
    What’s wrong?

    Ditto with Graphy theme!

    By the way I have the Tesseract theme

    We’re having the same problem with a custom theme (which worked on previous versions of Polylang, by the way). Saving the settings fixes the problem temporarily, but then the site goes back to showing the post list instead of the configured page.

    I have the same issue with optimize press. they don’t provide support. I tried everything noted above but it didn’t work. I posted a post yesteraday but it was deleted. Can I get some support? Thanks in advance

    I encountered the same issue with the latest Polylang 1.8.3 and WP 4.4.2.

    http://www.domain.com/en would give a 404 whatever settings I used. I digged in and found that renaming or disabling the custom taxonomy I use would make it work.
    Then I enable this custom taxonomy again and it continues to work unless the permalink rewrites are flushed.

    So there seems to be an issue related to custom taxonomies and permalink rewrites in Polylang.

    So if you have the same problem, and are using a theme with custom post type and custom taxonomies, check out this work around:
    – temporarily rename or comment out the custom taxonomy in your theme’s functions.php
    – check if it now works
    – set back the changes you made, and be sure not to flush permalinks.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Static homepage does not show with polylang plugin’ is closed to new replies.