WordPress.org

Forums

The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Static Home Page not showing anymore - now it's most recent posts (35 posts)

  1. MultiMatt
    Member
    Posted 6 years ago #

    I am using version 2.7.1 (I know, I need to upgrade - just need the time!).

    Today, out of the blue, my blog began posting the most recent posts I have made, on the Home page. The thing is, I have had it set since Day 1 to display a static Home Page that I created!

    The site is http://kaee.org if you want to see what I mean.

    I have gone into the Admin section and tried changing the Reading settings a couple different ways, and it doesn't change a thing.

    Help!

  2. henkholland
    Member
    Posted 6 years ago #

    Hi Mulitmatt,

    when you go into Admin and pages, does the static page that you selected for Home still exist?

  3. MultiMatt
    Member
    Posted 6 years ago #

    Yes, I have several pages that I have created over time, and all of them show in the drop-down for Front Page, including Home (other pages such as Contact Us, Membership, Newsletter, etc).

    I've tried selecting any of those pages to be the Front Page as well, and nothing changes. It's like I'm stuck in "Your Latest Posts" mode or something!

    I wouldn't think this has anything to do with being slightly outdated on my WP version, but perhaps something corrupted? These people I do the site for are freaking out that the Home page is not looking right! I'm swamped at my "real" gig, so I need to figure out a quick fix, and hopefully can upgrade WP somewhere in the next few weeks or something.

    UPDATE: I went to the site and navigated around some, to see what would happen. Interestingly enough, MOST of the other "pages" display just fine, with the exception of About Us. It does the same thing as Home - displays only the most recent posts. All other pages (Board of Directors, CONFERENCE, Contact Us, KAEE Awards, KAEE’s Stories, Membership, Newsletter, Resources/Links) display just fine.
    Thought that info might be helpful in determining the root cause...

    Thanks!

  4. henkholland
    Member
    Posted 6 years ago #

    Yeah and it looks like you have hardcoded Home now in the right hand menu. Because, if I hover over it , I see page_id=7

    I would not update before I solved the problem.

    You of course did a refesh in your browser window to reload your site, after setting agian the static frontpage.

    Then I would try re-uploading the file's in wp-admin and wp-include (version 2.7.1). They are on WordPress.org under release archive.

  5. MultiMatt
    Member
    Posted 6 years ago #

    I didn't actually hard code anything - when you create a new page, it gives the page an id, hence the Home page was the 7th page I ended up making!

    I tried your suggestion and nothing changed.
    Backed up my files and MySQL database, then went ahead and installed version 2.9. I chose the Install Automatically, and had the following error message:

    Warning: gzuncompress() [function.gzuncompress]: data error in (edited the path for this post)/html/wp-includes/http.php on line 1831
    WordPress upgraded successfully

    Nothing has changed. Here is an interesting finding, if it helps:

    I went into the Reading settings and changed the static Front Page to be the Board of Directors page. Refreshed and viewed the site. It still erroneously showed the latest posts, BUT I discovered that I could now click on Home and go to page_id=7 and see the home page! If I clicked on the BOD page, it went back to the latest posts. SO, it appears that it doesn't matter WHICH page I choose for the static Front Page, it ends up in the same scenario - wrongly showing the most recent posts instead of a static page.

    Any other suggestions? I am stumped...

  6. henkholland
    Member
    Posted 6 years ago #

    For the new problem (error on line 1831) I searched the forum and this looks like the best solution:
    http://wordpress.org/support/topic/342988?replies=12

    For the existing problem:
    Try switching to the Default theme for a short while and check what happens.

  7. MultiMatt
    Member
    Posted 6 years ago #

    Thanks for the tip on the line 1831 error!

    Question on switching the theme: I spent a bit of time tweaking some settings on the nonzero green theme I am using. I THINK I should be ok, because obviously the files I tweaked were within that specific theme folder in the wp-content directory, but I just wanted to check: If I switch themes, then switch back, will everything go back to the way I had it set?

  8. MultiMatt
    Member
    Posted 6 years ago #

    It just seems to me that there's a .php file somewhere that needs overwriting, which has some code in it to call up the right static page (or call up the latest posts, whichever the author chooses). I feel like I am going to open up a can of worms and have hours of re-work ahead of me if I change that theme!

    Everything works right on the site, with exception of the chosen static page not displaying... it's got to be one line of code somewhere, but WHERE is the question! :(

  9. henkholland
    Member
    Posted 6 years ago #

    Multimatt, switching a theme through Dasboard/Appearence will for that (short) time, totally change how your site looks. But you can then see if the static frontpage is the right one and if the page links work properly.
    It will not brake your own theme because that is in its own folder and you are not changing anything in these theme folders. You are just telling WordPress to load another theme.

    So: " If I switch themes, then switch back, will everything go back to the way I had it set? " Yes, it will, and offcourse you have a backup of your own theme om your computer, right. Because that one is not included in a WordPress XML export and (I think) not in a Database backup.

    Next, I do not think it is causedby a theme related php file (but then we would know) and since you have a fresh install it is not a php file problem of the other wp files. The setting is probaby wrtitten to a database table, like options.
    Yes, I checked, it is there:
    Option-ID Blog-ID Option_name Option_value Autoload
    285 0 page_on_front 96 yes (this is my static page nr/ID)
    286 0 page_for_posts 4264 yes (this is my posts-page nr/ID)

    But do not blame me if poking in the database goed wrong.

    Now that I played with the settings again: do you still have that empty page (only must have a title) called blog or posts that you have selected as the page to show your posts (the line under Settings/Reading below the one where you set your static page?
    And come to think of it, how did you navigate to your blog?

  10. russ.maschmeyer
    Member
    Posted 6 years ago #

    BUMP!

    I'm having the exact same problem. My site is located at http://yourpie.com. It was working fine not long about, but suddenly the home page disappears and it only shows the default blog page. You mentioned the database options table. Can you elaborate a bit more? I'm not sure I understand what to do to fix this.

    Thanks!

    R

  11. henkholland
    Member
    Posted 6 years ago #

    And Russ, I take it that this should be your homepage:
    http://yourpie.com/?page_id=3

    What was the name of your (empty) page that is selected to be the blog page? (in line 2 under Settings/Reading?

    Does that page still exist when you go to Dashboard/Pages?

    About the database question: you need database access to view tables there. If you never used that, do'nt go there. Too easy to make things worse.
    Otherwise view the wp-options table to find these lines:
    Option-ID Blog-ID Option_name Option_value Autoload
    285 0 page_on_front 96 yes (this is my static page nr/ID)
    286 0 page_for_posts 4264 yes (this is my posts-page nr/ID)

    The line numbers will be different and between () are my comments.

  12. MultiMatt
    Member
    Posted 6 years ago #

    I am lost when it comes to looking at the database in PHPMyAdmin. I see those different fields (Option-ID, Blog-ID, Option_name, Option_value, Autoload) in the wp-options table, but as far as editing to check what the static page nr/ID is, I have no clue!

    On my original settings, before all this began, I had my page titled HOME set as the static page (ID 7), and I had nothing selected for the posts page, because I would post to numerous categories, not just one particular page per se.

    Since then, I have tried creating a new blank page (called TEST), and setting it as the posts page, and still no improvement.
    I then tried selecting the TEST page to be the static page. When I did that, the HOME page link would now go to the correct path (http://kentuckyassociationforenvironmentaleducation.org/?page_id=7), and if you click on TEST, it (incorrectly) displays the most recent posts.

    Obviously changing settings via the control panel is not writing to the database correctly, right? I REALLY need to get this right - the group I do the site for is freaking out! Can you provide a little more explanation on how to edit that table?

    And I am still concerned as to how this could have happened when I made no changes to the site, yet one day it just starts showing like that! A database driven site has proven to be WAY more work for me than the old-fashioned way of using Dreamweaver to simply update pages! UGH!

    Thanks in advance for any help you can provide!

  13. henkholland
    Member
    Posted 6 years ago #

    Hi Multimatt,
    THIS IS STANDARD WP BEHAVIOUR. Rename test to blog and you are set.
    That static blank page is just a wp trick and you can still post in several categories. The blog page usually shows excerpts of all your posts, like you had before.
    Stupidly I never asked how you accessed your blogposts before.

    For direct access to a category you need these in your menu. The default theme has categories in the menu.
    So once again: "...and if you click on TEST, it (incorrectly) displays the most recent posts .." No, it correctly displays them.
    The original reason is I guess that you accidentely deleted the blank "blog aka test" page.

  14. russ.maschmeyer
    Member
    Posted 6 years ago #

    Yes that is the homepage. So it exists, and you can hard link to it. It just seems the "select a static homepage" feature within the WordPress backend seems to be screwing up now for some reason.

    I called the blank "blog" page "News" and have set that to use the default (index.php) template, which I've confirmed is coded to be the blog template. That's the page (News) I've chosen for the posts page.

    It definitely exists when I go to edit pages. I don't know what else to say. It's really weird. It was just working and now it isn't. The only thing I can think that may have disturbed it is updating my version of WordPress, but I did that months and months ago. Perhaps my client auto updated again recently and that's what caused it, but apart from that I have no idea what would cause that.

    Just thinking of it... there was one weird thing I noticed when my client first called my attention to the issue a couple days ago. All of the theme files had been weirdly pre-pended in with some massive string of ASCII code or something, like 40 lines of ASCII code or nonsensical letter streams wrapped in a PHP tag.

    It was really weird. I went through all the files and deleted it, thinking that might be the bizarre issue. But that didn't change anything. Thoughts?

  15. MultiMatt
    Member
    Posted 6 years ago #

    I appreciate your quick responses in attempt to help me!

    BUT,

    I've had this site (blog) running in the same setup for nearly two years, and I've never had the Posts page set to anything in the Reading settings. I purposely left it blank! I didn't want a page with posts to appear in the menu along with all of the "static" pages I created.
    If you look at my menuing: http://kentuckyassociationforenvironmentaleducation.org/?page_id=7
    you'll see how I have it set up, and it's been working fine that way all this time.

    That's what baffles me - I changed nothing, period, and this weird anomally happened. The only changes I have made in the past several months has been adding posts to categories such as News and Other EE Events from Around the State. That's it! I have created no additional pages, I have deleted no pages, and I have not been in the Admin Control panel to change anything!

    Doesn't matter which pages I choose for Static and Posts, whatever becomes static will now only show posts.

    I just don't get it! I could understand if I screwed with something, but I didn't, and this suddenly happened! When it did happen about a month ago, I hadn't made any edits in several weeks! One day it was displaying fine, the next day, my home page is the latest posts.

    End of novel!

  16. avidowl
    Member
    Posted 6 years ago #

    Hi,
    I found this thread searching for some help with the J Derek theme, it looks like a few months ago you had trouble with getting a static front page in the theme, and it that thread it said there was some bad coding in the theme but not what, any help would be greatly appreciated. thanks
    April

  17. russ.maschmeyer
    Member
    Posted 6 years ago #

    Hey Henkholland,

    So I went into my PHP database and it's showing the correct information. I have a screen shot, here's the link:

    Image

    That shows my posts page as ID=4, which it should be, and the home page with ID=3, which is correct as well. So, the back end has it right. The database has it right. The page exists and the template itself works (yourpie.com/?page_id=3) and is viewable. There just seems be some mysterious bug somewhere. It's being legitimately directed to show the posts page for the homepage SOMEWHERE. But Where? Is there a function somewhere that recognizes the database settings for the homepage that might be missing? Anyone? Beuller? Beuller?!

  18. esmi
    Forum Moderator
    Posted 6 years ago #

    Have you tried switching to the default theme to rule out any theme-related issues?

  19. russ.maschmeyer
    Member
    Posted 6 years ago #

    Yeah, I've switched it to the default theme. Tried re-uploading the default theme from the newest version of wp. All the templates behave the same way.

  20. esmi
    Forum Moderator
    Posted 6 years ago #

    Have you deactivated all plugins? Or tried resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  21. russ.maschmeyer
    Member
    Posted 6 years ago #

    Come to think of it, there is something screwy going on with the plugins. I'll try that really quick.

  22. russ.maschmeyer
    Member
    Posted 6 years ago #

    Well, that didn't do it. Neither the presence nor absence of plugins seems to affect the malfunction. It's still there going strong.

  23. russ.maschmeyer
    Member
    Posted 6 years ago #

    For those reading at home, I used the FTP reset of the plugins folder. Used FTP to change it's name to "plugins.hold" then checked my site's back end to confirm the disappearance of ALL plugins (which happened) and then reloaded the front end to see if that resolved the issue. It did not.

    I've now changed my "plugins.hold" folder back to "plugins"

  24. russ.maschmeyer
    Member
    Posted 6 years ago #

    bump!

  25. henkholland
    Member
    Posted 6 years ago #

    Hi Russ, I am out of answers, only questions left. What do you mean by this statement of yours:
    "I called the blank "blog" page "News" and have set that to use the default (index.php) template, which I've confirmed is coded to be the blog template. That's the page (News) I've chosen for the posts page."
    When I set a static frontpage and select a "News" page for my posts/blog and I select the radio button and hit save, it's a simple go.

    Set this way my news/blog page automatically uses 'index.php' I do not have to set the template and under template I can only leave it at default template or select my own homemade template's like my page_wide.php BUT NOT 'INDEX.PHP' It's not there in the box.

  26. zuhu
    Member
    Posted 6 years ago #

    The same thing is happening to me, no plugins installed, and on multiple themes.

    I also have not altered anything, my wife notified me our daughters school blog was not displaying homepage. I also got a gz-zip error on upgrade, and a couple more on the next upgrade.

    I pasted the http.php in from here and it still did not work.

    I have noticed the permalinks of the static 'frontpage' are not alterable and on mouseover they show the sites main index - clicking them displays the Recent Posts however.

    I have tried the Home and Blog settings, switched to default theme for a bit and clicked everything, and it still does not work. I am assuming for the time WordPress is well aware of the issue.

  27. MultiMatt
    Member
    Posted 6 years ago #

    zuhu,
    I know you assumed WordPress was well aware of the issue, but given the fact that there is still no answer and no acknowledgement from that I can find, I don't think we're going to get an answer any time soon.

    It's sad to have this happen, and even sadder that we can't seem to find out what is wrong and how to fix it. I appreciate everyone's attempts to help here, but thus far, I'm screwed. Site broken and I hadn't done anything to break it!

  28. tictok
    Member
    Posted 6 years ago #

    hmm... same thing just happened to me. Still trying to fix it.
    I've tried switching themes and back, disabling plugins, changing the Reading settings - everything I can think of. NO joy so far.

    Just before I noticed my static form page turning into a posts / blog page I noticed that the active page on any of the wp_link_pages throughout my site wasn't working. For example I could be on page 3 of multipage post / page (split up with nextpage tags) but the next page stays stuck on page one... wonder if its related?

    Will keep you posted if I find anything.

    cheers
    Stef

  29. tictok
    Member
    Posted 6 years ago #

    update: Fixed my issue... my own silly fault.

    I'd been messing around in the functions.php trying to conditionally load plugins based on page. Thought I had it working - appears I didn't after-all. Sorry for jumping on your thread.

  30. topexpert
    Member
    Posted 6 years ago #

    I had exactly the same problem. Tried disabling the obvious plugins and still had the same problem.

    Changed the theme still had the same issue.

    The issue being set 'Static Homepage' did not seem to work on one of my sites. In the end I renamed the directory ../wp-content/plugins to ../wp-content/deleted

    I then logged in to wp-admin loaded modules, got all the error messages stating that plugins could not be found and had been disabled. Refreshed the page and got confirmation there were no plugins.

    Checked homepage - problem resolved.

    I then went back and renamed 'deleted' to 'plugins' and the homepage still works

    Of course all the plugins are inactive now and will re-enable them and see which caused me the problem. In the meantime, dont just de-activate the plugin but remove them entirely and hopefully that will work for you guys too.

Topic Closed

This topic has been closed to new replies.

About this Topic