WordPress.org

Support

Support » Plugins and Hacks » Polylang » Static frontpage with /de loads blog archive

Static frontpage with /de loads blog archive

  • Hello,

    I installed ploylang yesterday and encountered a strange problem. English and german are used, english is default. Langage detection is turned on, static frontpage is checked.

    While english works, opening the frontpage in german (www.example.com/de) opens not the frontpage itself but the blog archive. The website is http://www.apiomat.com, but polylang is disabled for now.

    Thanks in advance!

    http://wordpress.org/extend/plugins/polylang/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Chouby

    @chouby

    This is the default behaviour of Polylang that http://www.example.com/de links to the blog archive. If you want that it links to you front page then you have to check: ‘Redirect the language page to the homepage’ in Polylang settings.

    Hi checked “When using static front page, redirect the language page (example: http://www.apiomat.com/en/) to the front page in the right language”, but it only works for the default language (en), de opens still the blog.

    After updating to 1.0, opening the blog with en shows no entries, but there are some selectable on the “recent posts” menu.

    Plugin Author Chouby

    @chouby

    Hi,

    1.0 ist actually installed, hence the additional problem with the blog showing no enries (see above)

    Hi,

    OK, after updating to 1.0.1 and thinking a while I think it works now; When clicking on “Home” after changing the language in the blog section, the frontpage was not opened because it did not exist in the selected language. Also, all other pages (tabs in the menu) are not visible when not translated.

    Is there any option to show all pages, even if they are not already translated?

    Best,
    Andreas

    Plugin Author Chouby

    @chouby

    Is there any option to show all pages, even if they are not already translated?

    I don’t understand what you mean.

    I mean: We have a static frontpage, the blog and two other pages shown in the main menu of our website apiomat.com. All these pages are in english. When I switch language to german, only the static frontpage is shown in the menu (the only page which exists in german, all others have no translation).

    So: is this normal behaviour? If yes, how can I get the blog back into the german menu?

    Plugin Author Chouby

    @chouby

    Yes. Your menu lists pages. And of course Polylang filters them by language. So if you don’t have any page in german, nothing will be displayed.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Static frontpage with /de loads blog archive’ is closed to new replies.
Skip to toolbar