Support » Plugin: Polylang » Static frontpage "?" url parameter URL language information

  • Resolved didoo

    (@didoo)


    Maybe is not a bug, or is a well-known behaviour.
    I’m using a static frontpage, and I have unchecked the “Hide URL language information for default language” option in the settings.
    What it happens is that when the URLs are called with the “? + parameters” then you get a 404 error page or a continuos redirection loop.

    Made a test with a fresh installation of WP: activated Polylang (latest), created two languages (IT + EN), added a “frontpage” page (in both languages). Then unckecked the “Hide URL language information for default language” on Polylang settings.

    When then I make a new post/page ad click on the preview this url is called:
    /?page_id=13&preview=true
    which gets redirected (302) to:
    /en/frontpage/
    which is the home/front-page, not the preview of the draft/page!

    Is the “Hide URL language information for default language” option not compatible with static frontpages?

    http://wordpress.org/extend/plugins/polylang/

Viewing 9 replies - 1 through 9 (of 9 total)
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Static frontpage "?" url parameter URL language information’ is closed to new replies.