Static front page unresponsive (4 posts)

  1. Goghard
    Posted 2 years ago #

    As many people, I'm trying to assign a page as the front page of my site (http://humanistainformatico.noblogs.org/). I followed this guide and this guide.
    I created a "Home" page and a "Blog" page, as the guides suggest, and I selected them in the "Reading Settings". But, the "Front page" menu box returns to "-select-" when I save the changes. So, I am unable to set any page as a static front page.
    Here is a screenshot of my problem: http://humanistainformatico.noblogs.org/?p=172
    I didn't installed WP myself; I'm using a hosted services called "noblogs.org".
    Any tips are appreciated.

  2. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Try clearing your caching plugin.

    If that does not work, try deactivating all plugins and switch to another default theme (twentythirteen) temporarily to see if it works there.

  3. Dave Naylor
    Posted 2 years ago #

    Did you publish the Home page?

  4. Goghard
    Posted 2 years ago #

    I'm really a newbie with WP; excuse me if I'm asking something very obvious, but really, I couldn't find an answer in the forum or in Google. I double checked and yes I published the home page; it appears in the "Front page" menu box (http://humanistainformatico.noblogs.org/?p=174).
    WPyogi: I went to the plugin section and all the plugins were deactivated (I don't know anything about WP plugins). Here is a screenshot: http://humanistainformatico.noblogs.org/?p=173
    May I ask you how can I clear my caching plugin? I didn't see an option.

Topic Closed

This topic has been closed to new replies.

About this Topic