Support » Theme: Customizr » Static Front Page Not Working

  • I am unable to set a static page as the Front Page using the Customizr theme. I’m following the directions (http://docs.presscustomizr.com/article/102-customizr-theme-options-front-page) to set my Front Page to a single static page (as opposed to showing my latest posts).

    When I do this, my site crashes and I receive this error message: ERR_TOO_MANY_REDIRECTS. The page suggests that I should clear my cookies. I’ve done this multiple times, and it does not fix the issue. As soon as I change it back to the “Your Latest Posts” option, the site works fine again.

    Has anyone else experienced this, and how did you fix it? I need to be able to build a static welcome page for the site, in addition to the amazing front page features provided by the theme (slider and featured pages).

    Thank you for any help you can provide.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi,

    I have never encounter this issue before, but the following are possible causes.

    One of your plugin could be having redirection codes, such as a plugin for front page login. Disable all your plugins and check whether your front page loads properly.

    If you have added any redirect codes in your .htaccess file, you will have to remove them. The file content should be automatically created by WordPress

    If you have any type of domain name redirection on your web hosting, it could also cause issues if not done correctly.

    Thank you

    • This reply was modified 2 years, 7 months ago by Denzel Chia. Reason: typo error

    Hi – Thanks for the reply. I tried disabling all the active plugins, and I still get the same result. I haven’t edited the .htaccess file myself, so it should be only what WordPress is creating. I haven’t added any domain name redirection, since I’m just creating a test version of the new site on 000webhostapp.com (before creating the real WP site on our paid hosting service), so I don’t think it’s that either…

    I’m at a loss. No one else has experienced this? It’s strange that it works fine with the latest posts, but crashes as soon as I choose a static page. Any other ideas? Thanks!

    Hi, was it possible for you to solve this issue?
    I have the same issue at the moment and already did the following:

    – Deactivated all plugins, still the same problem
    – Deleted the entire theme, still the same problem

    Not sure what I can do, any ideas?

    It works if if have set the permalink to “plain” .
    But it does not work if I set it to “postname”

    Thank you
    Matthias

    • This reply was modified 2 years, 2 months ago by matthes84.
    simonegirlanda65

    (@simonegirlanda65)

    I’m in the same situation.

    – new wordpress site created
    – all plugin disabled

    if permalinks set to something different from “plain”, I got the ERR_TOO_MANY_REDIRECTS in the home page.

    The error is present only in the home page, all other pages works fine.

    So accessing to site root page (http://www.mydomain.com) I got the error.
    The same page recalled with full path (http://www.mydomain.com/home) works.

    I’m using WordPress 4.8.2 in a Bitnami virtual machine.

    thinkDrew

    (@thinkdrew)

    Just as @simonegirlanda65 mentioned, I am also now receiving this error upon updating today… If I set the permalinks to “Plain” everything works fine (obviously not a fix) and when I try to convert my permalinks back to custom or something else, I get the ERR_TOO_MANY_REDIRECTS on my home page ONLY. The rest of the website works fine.

    STEPS

    • Upgraded to latest version of wordpress 4.8.3
    • After upgrade, home page throws ERR_TOO_MANY_REDIRECTS
    • Changing permalinks to “Plain” fixes the problem but not a solution
    • Changing permalinks back to custom structure or any other, reintroduces the ERR_TOO_MANY_REDIRECTS

    I do not have any redirection plugin installed.
    I have cleared cache.
    Reset permalinks.
    Un activated all plugins.
    Switched over to TwentySeventeen theme.
    Site URL’s are the same.
    Database URL’s are the same.

    What is going on here???

    I’m having the same problem. It’s not caused by the plugins, htaccess or wp-config. It only happens when switching to a static homepage. Any news on this?

    I am experiencing the exact same problem. My WordPress install is in a subdirectory of another site. When the site launches it shouldn’t be a problem.

    Adding /index.php to the url allows me to view my homepage without the error.

    Update, I have a domian now pointed at the install so I no longer have the sub directory in my WordPress URL or Site URL (or htaccess rules) but I’m getting the same result. Too many redirects error on static front page at domain root.

    Any insight is appreciated!

    My problem existed on a temporary url from my hosting party. changing DNS so the domain would be run on it’s final destination http://www.domain.com instead of domain.com.hostingparty.com fixed the problem for me.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Static Front Page Not Working’ is closed to new replies.