WordPress.org

Forums

Travelify
[resolved] Static Font Page - Are posts/pages required? (20 posts)

  1. suburbtosuitcase
    Member
    Posted 1 year ago #

    Hello. I really like this theme but I am wondering if I can select the static front page option without having to include an actual page or post at the bottom of the site. In other words, I would prefer my page to be navigated through the menus above the featured slider only. I prefer not to display any posts below the slider. I have placed a "dummy" page there currently until I determine if I can avoid this altogether with my viewers seeing a "No posts" message. Thank you for any guidance you can offer. I am a beginner WP user and my site is http://suburbtosuitcase.com.

  2. Balint Toth
    Member
    Posted 1 year ago #

    Hello!

    You should be able to hide it with this custom css code:

    .home #content  {
      display: none;
    }

    But make sure it doesn't hide anything else on other pages (it shouldn't, but just in case...)
    You should include this css code inside a child theme, this way ensuring that your changes won't be lost when you update your theme or WordPress. I have made a video tutorial how you can create one:

    [ link redacted, use this one instead http://codex.wordpress.org/Child_Themes ]

    If you have any more questions, just drop a line here, I am happy to help.

    Greetings,
    Balint

  3. suburbtosuitcase
    Member
    Posted 1 year ago #

    Thank you for your help, Balint! Great video - it has a patient pace and even as a beginner, I am following you due to your thorough explanations. However, I am part way through the tutorial and have run into a problem. I created the child theme as you indicated but when I tried to see if WordPress would recognize it under Appearance\Themes, it is not in my list. I am using a Mac with TextWrangler. Any thoughts about why WordPress may not be seeing it?

    Path to the child theme:
    /Users/sts/Documents/Documents/wordpress/wp-content/themes/travelify/travelify-child/style.css

    The style.css is as follows:
    /*
    Theme Name: Travelify Child
    Theme URI: http://colorawesomeness.com/themes/travelify/
    Author: Color Awesomeness
    Author URI: http://colorawesomeness.com/
    Description: Travelify is a clan, simple and fully responsive WordPress WooCommerce theme that looks awesome on any device. It adjusts automatically to any screen size including tablets and smartphones as well as Retina displays. Theme is built using HTML5 / CSS3 and is SEO friendly. This WordPress theme was built with travel, adventures, languages and nature in mind but it can be used for anything so be creative and unleash its full potential in blogging, ecommerce, business and other websites. Along the awesome design this theme is customizable via a simple but yet powerful theme options. Some of the nicest features are featured post slider, social icons, custom logo, translation ready and many more. This theme out-of-the-box plays nicely with WooCommerce, Breadcrumb NavXT, WP-PageNavi, Contact Form 7 and other popular plugins. Theme available in English, French, German, Hungarian, Italian, Spanish, Dutch and Chinese.
    Version: 1.3.7
    License: GNU General Public License v2 or later
    License URI: http://www.gnu.org/licenses/gpl-2.0.html
    Tags: white, light, green , custom-background, custom-header, custom-menu, flexible-width, featured-images, full-width-template, left-sidebar, right-sidebar, one-column, two-columns, three-columns, rtl-language-support, sticky-post, theme-options, threaded-comments, translation-ready, photoblogging, holiday
    Text Domain: travelify
    Template: travelify
    */

    @import url("../travelify/style.css");

  4. Balint Toth
    Member
    Posted 1 year ago #

    You have to create your child theme beside the parent theme's folder, not inside of it. So in the themes folder it should look like this:

    wp-content
        themes
            travelify
            travelify-child

    Greetings,
    Balint

  5. suburbtosuitcase
    Member
    Posted 1 year ago #

    Thank you Balint. I apologize that I did not follow the instructions correctly. I have made that change and have successfully activated the child theme. I confirmed this because I can see the following:

    Current Theme
    Travelify Child
    By Color AwesomenessVersion 1.3.7
    This child theme requires its parent theme, Travelify.

    Before I activated the child theme, in the style.css file in the travelify-child folder I inserted the text you have mentioned initially as follows:

    /*
    Theme Name: Travelify Child
    Theme URI: http://colorawesomeness.com/themes/travelify/
    Author: Color Awesomeness
    Author URI: http://colorawesomeness.com/
    Description: Travelify is a clan, simple and fully responsive WordPress WooCommerce theme that looks awesome on any device. It adjusts automatically to any screen size including tablets and smartphones as well as Retina displays. Theme is built using HTML5 / CSS3 and is SEO friendly. This WordPress theme was built with travel, adventures, languages and nature in mind but it can be used for anything so be creative and unleash its full potential in blogging, ecommerce, business and other websites. Along the awesome design this theme is customizable via a simple but yet powerful theme options. Some of the nicest features are featured post slider, social icons, custom logo, translation ready and many more. This theme out-of-the-box plays nicely with WooCommerce, Breadcrumb NavXT, WP-PageNavi, Contact Form 7 and other popular plugins. Theme available in English, French, German, Hungarian, Italian, Spanish, Dutch and Chinese.
    Version: 1.3.7
    License: GNU General Public License v2 or later
    License URI: http://www.gnu.org/licenses/gpl-2.0.html
    Tags: white, light, green , custom-background, custom-header, custom-menu, flexible-width, featured-images, full-width-template, left-sidebar, right-sidebar, one-column, two-columns, three-columns, rtl-language-support, sticky-post, theme-options, threaded-comments, translation-ready, photoblogging, holiday
    Text Domain: travelify
    Template: travelify
    */

    @import url("../travelify/style.css");

    .home #content {
    display: none;
    }

    When I visit my site, the main front page still shows the "No Posts Found" message. Any thoughts? Thank you again for your help!

  6. Balint Toth
    Member
    Posted 1 year ago #

    It is really interesting, because now the frontpage does not contain any div with a home class...

    I would ask, at this point what are your settings? Is it set to show up a static page, and set to a page with no actual content in it? Or you basically don't have any posts that it could list?

    Thank you!

  7. suburbtosuitcase
    Member
    Posted 1 year ago #

    Those are great questions. You are correct that I do not have any posts - everything right now is set to be a page. The current setting is set to do a static page but I did not select anything from the drop-down options. My thought was that I did not really want any posts to appear below my featured slider since I am using my site less as a blog and more as a website to steer people through the menus instead. To me, it's just a little "cleaner" that way. Does that help? You can feel free to tell me that's not a good idea. It was just my initial thought so it took me down the path of trying to remove that "No Posts Found." message. If the approach we used will not work, that's ok because you have been very helpful in creating the child theme which I am certain I will need and use going forward as well.

  8. Balint Toth
    Member
    Posted 1 year ago #

    No, that is a completely fine way to use WordPress.

    Regarding the notification hiding, I have come up with a crazy idea :-)

    At this point there is no way to target the No posts found text from CSS in order to hide it. So I would like to ask you to create a post, with a single space in it's name and it's content box, and save that. That post will have an unique id, which we can target to hide it completely. After that, we will just adjust the paddings if necessary.

    Because there is no way from my end to tell upfront what ID the post will get, please let me know when you have added that post.

    Greetings,
    Balint

  9. suburbtosuitcase
    Member
    Posted 1 year ago #

    Your crazy idea is very creative. The post ID is 1539. It has a single space in both the title and body.

  10. Balint Toth
    Member
    Posted 1 year ago #

    Thank you! Here is the css code which will hide it, just paste it under the previous code:

    #post-1539 {
        display:none;
    }

    I am afraid that the remaining whitespace cannot be deleted because of the targeting issue, because in current css rules, there is no way to say I want to hide #post-1539's parent div...

    I hope this helps.

    Greetings,
    Balint

  11. suburbtosuitcase
    Member
    Posted 1 year ago #

    Thank you! This is so close to resolving my issue. The only thing that's left now on the bottom of the page is a box that I don't remember seeing before that has my mailto address, date, an icon for uncategorized and an icon for no comments with a button to read more. Is that what you are referring to that cannot be deleted or is this something else that I have an option to turn off? I am sorry to keep pestering you on this. I really appreciate your help! I don't mind if there is white space - I would just rather remove the box that I described that appears to be something new or something I had not noticed previously. Thanks!

  12. suburbtosuitcase
    Member
    Posted 1 year ago #

    The only other thing I can think of that might be causing that is that in order to create the featured slider, those had to be created as featured images in individual posts. Perhaps that is the cause? Just a guess.

  13. Balint Toth
    Member
    Posted 1 year ago #

    No, actually that is what should have disappeared with the code I have provided.

    From my side it looks like that the css code

    #post-1539 {
        display: none;
    }

    is missing from the child theme's style.css, screenshot here:http://d.pr/i/S0LS

    Could you please check on your side also?

    And I would like to ask, are you using some sort of caching plugins?

    Thank you!

  14. Balint Toth
    Member
    Posted 1 year ago #

    That is true that the slider images are coming from posts, but this is the reason why we targeted that specific post with it's unique ID to hide it...

  15. Balint Toth
    Member
    Posted 1 year ago #

    Did you check your child theme's file (see 2 posts above)?

  16. suburbtosuitcase
    Member
    Posted 1 year ago #

    I'm stumped. The only plugins I have active are as follows:
    Akismet, Hide My Site, Jetpack by WordPress and WordPress Importer

    I think my child theme style.css below may already be up to date but I can certainly try to double check it:

    /*
    Theme Name: Travelify Child
    Theme URI: http://colorawesomeness.com/themes/travelify/
    Author: Color Awesomeness
    Author URI: http://colorawesomeness.com/
    Description: Travelify is a clan, simple and fully responsive WordPress WooCommerce theme that looks awesome on any device. It adjusts automatically to any screen size including tablets and smartphones as well as Retina displays. Theme is built using HTML5 / CSS3 and is SEO friendly. This WordPress theme was built with travel, adventures, languages and nature in mind but it can be used for anything so be creative and unleash its full potential in blogging, ecommerce, business and other websites. Along the awesome design this theme is customizable via a simple but yet powerful theme options. Some of the nicest features are featured post slider, social icons, custom logo, translation ready and many more. This theme out-of-the-box plays nicely with WooCommerce, Breadcrumb NavXT, WP-PageNavi, Contact Form 7 and other popular plugins. Theme available in English, French, German, Hungarian, Italian, Spanish, Dutch and Chinese.
    Version: 1.3.7
    License: GNU General Public License v2 or later
    License URI: http://www.gnu.org/licenses/gpl-2.0.html
    Tags: white, light, green , custom-background, custom-header, custom-menu, flexible-width, featured-images, full-width-template, left-sidebar, right-sidebar, one-column, two-columns, three-columns, rtl-language-support, sticky-post, theme-options, threaded-comments, translation-ready, photoblogging, holiday
    Text Domain: travelify
    Template: travelify
    */

    @import url("../travelify/style.css");

    .home #content {
    display: none;
    }

    #post-1539 {
    display:none;
    }

  17. suburbtosuitcase
    Member
    Posted 1 year ago #

    Oh my gosh Balint, it worked!! I have no idea how it suddenly is fixed, but maybe it required mr to delete the child theme and reinstall it (which I believe I did). Either way, I think I'm all set now. Thank you so much for all of your patience and support. I really appreciate it!

  18. suburbtosuitcase
    Member
    Posted 1 year ago #

    {Questions answered and site working well, so marking this topic as resolved.}

  19. Jagen Michael
    Member
    Posted 1 year ago #

    How can I stop the READ MORE link on my posts from going back to the homepage, I am displaying ALL TEXT why is READ MORE link on post ? I have applied DISPLAY NONE to CSS to hide author, date & category

    http://www.tigertracks.us

  20. suburbtosuitcase
    Member
    Posted 1 year ago #

    In order to people to reply to your question, you need to open a new topic and thread. This thread is closed and marked resolved.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.