Support » Plugin: WP-Optimize - Cache, Clean, Compress. » static file headers

  • Resolved yastychef

    (@yastychef)


    How can I disable the Static browser file cache settings (via headers)?

    The browser’s static file cache header is currently enabled.
    How can I undo this?

    The Numbers have dissapeared to reduce it down to zero.
    I have no control about it anymore now.

    Since I have turned it on, I have an displaying error on my page on the backend side and I want to turn it off to see if it is the reason.

    What can I do?

    I also tried deleting and re-installing the plugin, but it reamains enabled the same way.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Marc Lacroix

    (@marcusig)

    Hi there,

    If the cache headers were added via WP-Optimize, and the setting has disappeared (it shouldn’t), you’ll have to remove them from your website’s .htaccess.

    You can remove the section within the comments # BEGIN WP-Optimize Browser Cache:

    # BEGIN WP-Optimize Browser Cache
    <IfModule mod_expires.c>
    	ExpiresActive On
    	ExpiresByType text/css "access 1 month"
    	ExpiresByType text/html "access 1 month"
    	ExpiresByType image/gif "access 1 month"
    	ExpiresByType image/png "access 1 month"
    	ExpiresByType image/jpg "access 1 month"
    	ExpiresByType image/jpeg "access 1 month"
    	ExpiresByType image/webp "access 1 month"
    	ExpiresByType image/x-icon "access 1 month"
    	ExpiresByType application/pdf "access 1 month"
    	ExpiresByType application/javascript "access 1 month"
    	ExpiresByType text/x-javascript "access 1 month"
    	ExpiresByType application/x-shockwave-flash "access 1 month"
    	ExpiresDefault "access 1 month"
    </IfModule>
    
    <IfModule mod_headers.c>
    	<filesMatch "\.(ico|jpe?g|png|gif|webp|swf)$">
    		Header set Cache-Control "public"
    	</filesMatch>
    	<filesMatch "\.(css)$">
    		Header set Cache-Control "public"
    	</filesMatch>
    	<filesMatch "\.(js)$">
    		Header set Cache-Control "private"
    	</filesMatch>
    	<filesMatch "\.(x?html?|php)$">
    		Header set Cache-Control "private, must-revalidate"
    	</filesMatch>
    </IfModule>
    
    #Disable ETag
    FileETag None
    # END WP-Optimize Browser Cache

    Though the setting itself shouldn’t disappear.

    Since I have turned it on, I have an displaying error on my page on the backend side and I want to turn it off to see if it is the reason.

    Could you share a screenshot of the error?

    Marc.

    Thread Starter yastychef

    (@yastychef)

    Thanks for the reply,
    well I honestly dont understand much of what u´re talking about, I cannot code and dont speak php.

    Here is a screenshot:
    https://www.yasty.de/wp-content/uploads/2020/05/2020-05-20-at-14-00-35.jpg
    As you see there is no option anymore to turn it off. So I cannot find out it is the reason for my error.

    I dont know if this is the reason for the problem, but it happended after I turned that on.

    Either my page builder doesent load anymore or the elements like texts multiply by 4 in the backend.

    Plugin Support Marc Lacroix

    (@marcusig)

    I doubt that browser caching is the issue, but Here’s how to disable browser caching, when the option is gone from the admin (which shouldn’t happen):
    – using a FTP client (e.g. Filezilla) or a file browser on your hosting solution, browse to the root of your website.
    – Make a backup of that file, just in case something goes wrong.
    – In there, you’ll find a file named .htaccess, which contains the browser cache instructions.
    – Choose to edit this file (you might have to download it).
    – Delete what’s between # BEGIN WP-Optimize Browser Cache and # END WP-Optimize Browser Cache, as well as those two lines.
    – Save the file (if you had to download the file, upload it back on the server).

    That’s enough to deactivate the setting.

    Note that if https://www.yasty.de is the site you have the issue with, the setting will still appear enabled, because Cloudflare is enabled, and provides browser cache.

    Plugin Support Marc Lacroix

    (@marcusig)

    Also after opening your browser’s console (how to), you may want to share some screenshots of the issues (not WP-Optimize settings), and any error displayed in the console. This could help diagnose the problem.

    Marc.

    Thread Starter yastychef

    (@yastychef)

    Hey Thanks Marc for your advice,
    well yes that is the domain and now I have turned cloudflare off for a while and the setting (to turn static file header off) appeared again.

    Obviously WPoptimize didnt cause the displaying error, cause it is still there.

    Probably is has to do with cloudflare.

    So okay, there is something now that keeps me busy and I dont know what it is.

    However thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘static file headers’ is closed to new replies.