Support » Plugin: Autoptimize » Static cookieless domain path broken when using Autoptimize

  • Resolved sinorgpl

    (@sinorgpl)


    hello,

    This is basically 100% this issue https://wordpress.org/support/topic/static-file-domain-does-not-work-with-relative-path-css-fonts/

    I have configured my site to use a cookieless domain to serve static files.

    define("WP_PLUGIN_URL", "https://static.protestkit.eu/plugins");
    define("WP_CONTENT_URL", "https://static.protestkit.eu");
    define("COOKIE_DOMAIN", "www.protestkit.eu");

    The domain static.protestkit.eu/ points to absolute path

    /domains/www.protestkit.eu/wp-content/

    It works on 99% of files, except those optimized by Autoptimize (no errors when I disable the plugin).

    With Autoptimize error 404:
    https://static.protestkit.eu/wp-content/plugins/wp-optin-wheel/public/img/wheel-yellow.png

    Without Autoptimize:
    https://static.protestkit.eu/plugins/wp-optin-wheel/public/img/wheel-yellow.png

    Compare pictures here: https://imgur.com/a/bM2k47x

    I really want to keep using Autoptimize, but i don’t want to sacrifice one performence tweak for another. Is there an easy fix?

    thank you in advance!

    • This topic was modified 5 months, 1 week ago by sinorgpl.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    The domain static.protestkit.eu/ points to absolute path

    /domains/www.protestkit.eu/wp-content/

    you’ll have to have it point to /domains/www.protestkit.eu/ instead, AO does everything relative to wp-content I’m afraid.

    hope this helps,
    frank

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.