Support » Plugin: Google Pagespeed Insights » Start reporting run in background but not see reports

  • Vincenzo

    (@vluongo)


    Hi,
    I run Start Reporting and out this message

    Starting Reporting. Google Pagespeed will work in the background to load and report on each URL. The amount of time needed to complete all reports will vary depending on how many URLs there are to check, and how long it takes for Google to load each page on their servers. You can navigate away from this page if desired.

    But after 3 days , i don’t see any reports or data.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Matt Keys

    (@mattkeys)

    Hi Vincenzo,

    Can you make sure you are on the latest version of the plugin (4.0.2)?

    If you have access to your sites error logs (php) can you let me know if there are any errors from the plugin?

    I have seen people with the same symptoms as you in the past have success after carefully creating a new API key, making sure to enable the Pagespeed Insights API, and to not put any restrictions on the key.

    Vincenzo

    (@vluongo)

    Hello,
    yes I have the latest version installed and created a new key several times and I don’t find any error in php logs.
    how could i help debug?

    Vincenzo

    (@vluongo)

    Hi,
    After long time, i get more error same this

    Lighthouse returned error: NO_FCP. Something went wrong with recording the trace over your page load. Please run Lighthouse again. (NO_FCP) (NO_FCP)

    Can i fix it?

    Thank you

    Plugin Author Matt Keys

    (@mattkeys)

    Where are you seeing this error?

    Is you page able to be scanned using the google hosted pagespeed tool here:

    https://developers.google.com/speed/pagespeed/insights/

    Plugin Author Matt Keys

    (@mattkeys)

    When you look at the Google Console API metrics, what do you see? Here is a screenshot of what mine looks like after doing a quick test:

    https://cloudup.com/c5L2VYTCOBT

    You will see that there were 4 request to the “pagespeedonline.pagespeedapi.runpagespeed” method and 0 errors.

    I reached this screen by:

    1. logging in to https://console.developers.google.com
    2. Clicking the “PageSpeed Insights API” link from the dashboard
    3. Clicking “Metrics”

    Hi,
    yes, this is a my screen: https://snag.gy/MyjkZO.jpg

    Plugin Author Matt Keys

    (@mattkeys)

    Can you look in this table in your database and let me know if there is any data? wp_gpi_page_stats (your site might use a different prefix than wp_).

    This is where the page reports are stored after they are received from the API.

    yes, this is a dump of table:
    https://file.io/CKd9mt

    Plugin Author Matt Keys

    (@mattkeys)

    That link doesn’t work for me, but I probably don’t need it.

    It sounds like everything is working properly, you do not see any reports visible in the plugin?

    Do you see any JS errors in your browser developer tools console?

    sorry, new link: https://tmpfiles.org/dl/19018/wp_gpi_page_stats.zip

    and i not have any error from chrome console log: https://snag.gy/FI2zWa.jpg

    Plugin Author Matt Keys

    (@mattkeys)

    What problem are you asking for me to help you resolve?

    You opened this ticket saying that you were not seeing any reports or data. But your screenshot shows that there are lots of reports visible in the plugin.

    yes, suddenly (after days) he uploaded some data. these data are not complete, pages and articles are missing. plus you don’t have desktop or mobile data or even both on many pages (as you can see from the screenshots)

    Plugin Author Matt Keys

    (@mattkeys)

    The most likely scenario is that your hosting provider is stopping the process from the plugin before the Google API is able to respond with the results of the scan.

    This issue becomes more common and more likely on lower-scoring pages as those pages take longer for Google Pagespeed to scan.

    There is not a ton that I can do as the plugin author to work around this issue. However there is one feature of the plugin that you can try. Check out the ‘Maximum Script Run Time’ feature in the Advanced Configuration area of the options. This will set a limit on how long the plugin will allow itself to run before ending the process and starting a new one. Ideally you will put this value to a setting just under the maximum time your hosting provider will allow a script to run (although these values are usually not advertised).

    Give it a try and see if that helps.

    Beyond that setting, starting to fix the issues that you are seeing in the reports will help these scans finish quicker, and hopefully that would also resolve the issue.

    I have this issue but in my case, nothing is written to the database either

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.