WordPress.org

Forums

Start mutisite in subdomain (7 posts)

  1. CranialBlaze
    Member
    Posted 2 years ago #

    Is it possible to setup a mutisite from within a subdomain, not looking to convert my main site to a multisite, but when I tired I just ended up with errors or could not log in, strange paths and all that.

    I was basically looking at starting the MS at nms.domain.ext and having the multisites sit at nms.domain.ext/site2.

    Is what I am trying to do possible or do I need to buy a new domain as to not interfere with my live site?

    Thanks

  2. Totally doable. Install Multisite at nms.domain.ext and have it make subfolders and not subdomains :)

  3. JHouse
    Member
    Posted 2 years ago #

    So, installing Multisite is okay in a subdomain? Didn't know that, thanks for the info. Is it just a problem when you want to enable Domain Mapping?

  4. CranialBlaze
    Member
    Posted 2 years ago #

    @Mika

    Is there anything then that I am supposed to do as the default config gets me stuck on the login pge, keeps redirecting to the re-auth login.
    ANy modifications I make to the config myself either end up in some redirect loop or the wrong place.

  5. CranialBlaze
    Member
    Posted 2 years ago #

    Cant edit pot, anyway.

    I started from scratch and the networking part is working now. I have set it up to use the subfolder option which is working for the most part, but when I visit the site its unstyled as the stylesheet hits a 404 and the wp-admin ends up with a redirect loop.

    I then updated the htaccess file as I saw there where changes in admin, now I cannot log in again.

  6. So, installing Multisite is okay in a subdomain? Didn't know that, thanks for the info. Is it just a problem when you want to enable Domain Mapping?

    It's not a problem for anything. You can map sub.domain.com/foo to foo.domain.com even. Subfolder installs (i.e. domain.com/wordpress/) can be problemaitic.

    but when I visit the site its unstyled as the stylesheet hits a 404 and the wp-admin ends up with a redirect loop.

    Sounds like allowoverride isn't set to All (or Options All) on your httpd.conf

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.