Support » Plugin: WP Store Locator » Start Marker is Placed on the Equator Near Africa

  • Resolved Dave

    (@csn123)


    I have installed the plugin and set it up as directed in the documentation.

    I followed this advice but still have a problem with the start marker placement.

    I have tried entering an address – 10 Downing Street, London, SW1A 2AA, United Kingdom – and the set of coordinates – 51.503363, -0.127721 – into the Start Point field. Each time I reload the map page the Start Point marker is located off the African coast, presumably as a 0,0 location. I also tried entering the variants London and London, United Kingdom, all without success.

    The start location address data saves correctly to the wpsl_settings database field in the WordPress options table. I have set my map language as English [Great Britain], the map region to united Kingdom and have restricted the geocoding to the map region. I have turned auto-locating off in case this was failing.

    The store locations map perfectly.

    I have ruled out plugin conflicts and I don’t have a caching plugin yet.

    It sounds to me the data isn’t being correctly passed to the front end, resulting in false start co-ordinates.

    Is there a way I can check the data is correctly being fed to the front-end in the source code? I’m not sure what I should be looking for.

    https://wordpress.org/plugins/wp-store-locator/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Tijmen Smit

    (@tijmensmit)

    If you go the store locator settings page, scroll down to the “Tools” section, and clear the store locator transient cache. Does it still not work?

    If you enter the address for the start location on the settings page, does it autocomplete? If not, then here is probably a JS conflict in the admin area breaking it.

    If you view the source of the page ( ctrl+u in Firefox ), and search for ‘zoomLatlng’ does it say something else other then 0,0?

    Clearing the cache doesn’t change anything.

    The address doesn’t autocomplete in the admin. Checking my (Firefox) browser errors it comes up with this:

    Error: TypeError: google.maps.places is undefined
    Source File: /wp-content/plugins/wp-store-locator/admin/js/wpsl-admin.min.js
    Line: 1

    Viewing the source for the map display page it reveals:

    "zoomLatlng":""

    It sounds like a JS conflict might be the issue here.

    I think my theme might have been interfering with the code somehow. I disabled all the plugins, switched the theme over to the default TwentySixteen theme and could see the dropdown box.

    I’ve set the default address and reverted all other changes. Everything now looks and works like it should.

    Many thanks for your help!

    Plugin Author Tijmen Smit

    (@tijmensmit)

    Good to hear it works again. I will add a backup option to set the start coordinates directly in a future update.

    Just wanted to add that I had the same issue. I disabled all plugins like Dave mentioned above and was able to get things working.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Start Marker is Placed on the Equator Near Africa’ is closed to new replies.