Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Daniel


    When you activated the star rating for pages, did you check the box beside pages or did you choose individual pages from the pop up window?

    If you checked the box beside pages, within the settings page, then the star ratings will be added to all pages automatically.

    If you want to add the ratings to certain pages only, you only need to select them by clicking on the Choose Individual link and then select the pages you want the star rating to appear, but DON’T check the box beside pages.

    I hope this helps.

    Hi Daniel thanks for your answer, i think is something more complex, i try to explain:
    if the ‘pages’ box is checked, it obviously display the star rating on all the pages, then, if i select example: 2 pages on 3, it leave the stars and ratings displayed correctly on the 2 pages selected but on the 3rd (unchecked), instead of removing the plugin, it leave the stars displayed but the ratings are empty ..

    this is the code returned from the ‘non selected’ page. As you can see something gone wrong:

    <div id=”wps-seo-booster-2″ class=”wps-seo-booster-star-ratings open bottom-left”>
    <div class=”seo-booster-stars-turned-on”> </div>
    <div class=”seo-booster-hover-panel”>

    <div class=”seo-booster-casting-desc”></div>
    <div class=”seo-booster-casting-thanks”>Thanks!</div>
    <div class=”seo-booster-casting-error”>An error occurred!</div>
    <!–.wps-seo-booster star-ratings–>

    <!– You can start editing here. –>

    <!– If comments are closed. –>
    <!–<p class=”nocomments”>Comments are closed.</p>–>

    I hope you have understood.
    Many thanks for your support!

    Also found an error in my log, but don’t know if relative to the issue above:

    PHP Warning: Division by zero in /public_html/blog/wp-content/plugins/wp-social-seo-booster/includes/wps-seo-booster-star-rating.php on line 260

    Help please.

    Plugin Author Daniel


    No it’s not more complex. Have you checked the ‘pages’ box?

    yes, is checked
    ..and 2 pages are selected, but the stars are displayed on 3 pages (correctly on the 2 selected – with error on the third unselected).
    You can see third unselected page (where the stars should not be present, because the page is not selected) in the author page i provided in the first demand.

    Plugin Author Daniel


    ok, that’s the problem. As stated in the manual and shown in the video, if you just want to select individual pages, then your nee to uncheck that pages box. Checking the pages box means, all pages are selected, doesn’t matter what you choose within the individual entries.

    So please uncheck the pages box and the stars will disappear.


    They are gone ..i feel stupid.
    Thanks so much Daniel for all your time and help you promptly provided me, your plugin is simply great!
    All the best,

    Plugin Author Daniel


    Hey Jeff,

    You’re welcome. And no problem, I’m here to help.
    Thanks for your kind words. I’m glad you like the plugin.

    All the best,

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘stars do not disappear’ is closed to new replies.