WordPress.org

Support

Support » Plugins and Hacks » WP Social SEO Booster - Knowledge Graph Social Signals SEO » [Resolved] Star Ratings not working when wp-admin is password protected

[Resolved] Star Ratings not working when wp-admin is password protected

  • Hey Daniel,
    Cool plugin! I really appreciate what it has to offer.

    I’m having trouble though, getting the star rating shortcode to work with wp-admin password protected…

    When a new user loads a page with the shortcode on it, they receive a pop-up box asking them to log-in to wp-admin. After clicking past it without a password, it then asks them to log-in every time they click the stars to rate that product/page, etc.

    How can we get around this and while keeping wp-admin secure?

    Thanks in advance!

    http://wordpress.org/extend/plugins/wp-social-seo-booster/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Note: it works fine when I’m logged-in.

    Plugin Author Daniel

    @dwaser71

    Hi,

    Thanks a lot for your kind word. They are truly appreciated.

    About the star rating. This is a bit of a drawback from WordPress itself, because the ajax functions are only available through wp-admin and they don’t have one for the front end.

    The Ajax is needed for the star rating to get updated after a user has given a rating.

    I found a great article which does explain that in detail and this article does include links to other resources which do show how to protect wp-admin and still give access to the Ajax function.

    You can find the article here:

    AJAX Not Working For WP-Email, WP-Polls, WP-PostRatings or WP-PostViews?

    I hope this helps.

    Regards,
    Daniel

    Thanks for taking you time to find this, Daniel.

    I added the first box of code on this page, which was linked to from the article you referenced and that worked!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Star Ratings not working when wp-admin is password protected’ is closed to new replies.
Skip to toolbar