Support » Plugin: Stackable - Gutenberg Blocks » Stackable Theme width issue

  • Resolved Egor Milyukov

    (@milukove)


    Hello! Thanks for this awesome plugin, and for the free theme that you made especially for it.

    I found a small problem with this theme. It appears in my site as long as in your site. Maybe it is browser specific problem, I tested it only in Chrome on MacBook.

    So, the problem is a horizontal scroll, that appears when I add Header block with full-width alignment. Maybe with other full-width blocks too. To prevent this you should add custom style to the body: overflow-x: hidden. I guess it is relevant to ‘width: 100vw’, that doesn’t count browser scrollbar width.

    Don’t know, where to write about theme issues, so forgive me if this topic doesn’t belong here.

    It will be very nice of you to fix this in future theme updates 😉

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Benjamin Intal

    (@bfintal)

    Hi Egor,

    Thanks for the report. The Stackable theme was recently updated to v1.0.3, and Stackable to v1.11. I’ve checked the site in Chrome and MacBook and I don’t see the problem.

    I’m unsure whether this has been fixed because of the update, but can you check on your end if the issue is still present?

    Hi! Thanks for your answer!

    I figured out one thing. I guess this issue related only to macOS users.

    You see, there is “Show scroll bars” setting, that changes browser scroll bar behavior. If it is set to “Always” — there is horizontal scroll appears. Switch to Auto or When scrolling, and the scroll is gone.

    Settings screenshot

    The only solution I find by this time is adding overflow property to the body. Maybe there is another, better way. What do you think?

    Plugin Author Benjamin Intal

    (@bfintal)

    Hey Egor,

    Thanks, I didn’t know there was such an option in MacOS 🙂

    I saw the scrollbar you were talking about. You’re right, it’s caused by anything full-width in the Stackable theme.

    After some investigation, I think the only solution right now is the one you suggested:

    body {
        overflow-x: hidden;
    }

    I’ll be adding that to the theme, thanks!

    Happy to help, thank you for your work, Benjamin!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Stackable Theme width issue’ is closed to new replies.