Support » Plugin: Seriously Simple Podcasting » SSP-generated URL is NOT where podcast uploads to…anybody??

  • Has nobody else had this problem where, after uploading a podcast, it appears on the post or page where you said it should, but the links to the podcast on that post or page are incorrect?

    When I upload a podcast using the Add New admin menu item, the file ends up in the WordPress Media library, but the link to play or download it that appears with the player indicates a directory called “podcast-download” followed by a number and then the file name. The player doesn’t play anything and the play time shows “0:00”.

    I’ve tried it on 2 websites with different themes and get the same result, so I can’t be the only one having this problem. Sure would appreciate it if someone could chime in and offer some suggestions, because I’m stumped.

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • This is the same problem that I have, and I posted it over a week ago: https://wordpress.org/support/topic/shortcode-broken-5/

    So far, no reply.

    I’m starting to wonder if the author has abandoned these forums completely.

    Yep. Same issue. Would love a response.

    I fixed my issue by putting this code inside my Functions file.

    <?php
    add_filter( 'ssp_episode_download_link', 'ssp_use_raw_audio_file_url', 10, 3 );
    function ssp_use_raw_audio_file_url ( $url, $episode_id, $file ) {
      return $file;
    }

    @sethnieman

    Nice to see that you fixed it. However since the support here is equal to zero, I bit the bullet and switched to Podlove instead. Seems solid, but then again, so did SSP when I picked that…

    Thread Starter Springtide

    (@reneyoung)

    The code above did not fix the issue for me. Since no help appears to be forthcoming, we must move on.

    Plugin Author Craig Hewitt

    (@podcastmotor)

    Hi Rene,

    I’m looking into this with our lead developer and will get an answer for you shortly.

    Could you share a bit more about what website(s) you’re seeing this on? We’re not seeing it on local or production sites that I have the plugin running on, so an example would be helpful for us to check out.

    Thanks for the heads up and for your patience.

    Craig

    • This reply was modified 4 years, 1 month ago by Craig Hewitt.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘SSP-generated URL is NOT where podcast uploads to…anybody??’ is closed to new replies.