WordPress.org

Forums

Seriously Simple Podcasting
[resolved] SSP Fatal Error (5 posts)

  1. austinjhoffman
    Member
    Posted 1 year ago #

    Hello,

    I tried to install the SSP plugin, and everything appeared to be successful. However, this plugin has now broken every other page within the WP dashboard. I get the message:

    Fatal error: Call to undefined function wp_enqueue_media() in /home/content/16/6313416/html/FirstBaptist/wp-content/plugins/seriously-simple-podcasting/classes/class-seriously-simple-podcasting-admin.php on line 58

    I cannot navigate anywhere within the WP dashboard. Can anyone help me fix this or uninstall the plugin?

    http://wordpress.org/plugins/seriously-simple-podcasting/

  2. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 1 year ago #

    If you update to WordPress v3.6 then this will be fixed. My apologies - I will release an update that caters for older versions of WordPress ASAP.

    Sorry about that - I forgot to cater for that function in version of WordPress prior to v3.6.

  3. austinjhoffman
    Member
    Posted 1 year ago #

    Any help on doing so? I only know enough about WordPress to be dangerous. I can't navigate to the dashboard at all.

  4. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 1 year ago #

    Your best bet would be to install the previous version of the plugin (v1.6.1). You can download it from here: http://downloads.wordpress.org/plugin/seriously-simple-podcasting.1.6.1.zip. Just delete the existing plugin folder and replace it with the contents of that ZIP file. Your WP dashboard will prompt you to update to v1.7, but you can ignore that prompt. When you see the update for v1.7.1 become available then you will be able to safely update to that as I will include the fix for this in that version.

    I will post on this thread once v1.7.1 has been released so you will know when to check for the update.

  5. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 1 year ago #

    I will be releasing v1.7.1 later today, but I made a mistake in my previous post on here. Due to recent updates to WordPress and this plugin, you MUST be running WordPress 3.5 or above in order to be able to upload your plugin audio file or podcast image from the WordPress dashboard. You will still be able to paste a URL of a file in a different location, but if you are using the dashboard to upload your audio file then you will need to update to the latest version of WordPress.

    You should always be updating anyway - older versions of WordPress are much more susceptible to attacks that could damage your site and your data.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Seriously Simple Podcasting
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic