• Resolved bepositiv

    (@bepositiv)


    I’m using PowerPress. I am suddenly receiving an error when I attempt to add a podcast to a blog post: cURL error 35: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure. According to Siteground engineers, they recommend “contacting the plugin developer and ask them to use TLSv1.2 encryption protocol instead of SSLv3.” Any thoughts on this?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Angelo Mandato

    (@amandato)

    Hello ,

    This is an odd error. Unfortunately PowerPress does not manage SSL handshakes. This is all handled under the hood by the server’s configuration that PowerPress (and WordPress) runs within. There are two situations: either you have and are using the library called “curl”, or you are not using curl. If you go to PowerPress Settings > Tools, click on Diagnostics link and it will tell you if you have curl or not on that page. Depending on this answer I can give you further advice how to diagnose the issue with your server.

    I tested your site with Qualys SSL labs test: https://www.ssllabs.com/ssltest/analyze.html?d=www.doncrawley.com&latest and see that your server does not support SSL3 which is good. I do see some other issues, you should pass this url back to your web hosting to resolve them but they should not stop WoordPress/PowerPRress from making a connection like you are describing.

    More importantly, what is the media URL you are entering that gives you this error. We would like to test it in our sandbox. One problem maybe that your local server is not routing correctly back to itself, which would cause the SSL problem like you are describing.

    Please reply with:

    • IF you have CURL or not enabled on your server
    • URL to your media file you had the issue with

    Thanks,
    Angelo

    Thread Starter bepositiv

    (@bepositiv)

    Thank you so much for your response. I tried to find PowerPress Settings>Tools. I’m probably looking right at it, but I don’t see it. Also, here is the media URL: https://www.doncrawley.com/podcasts/20200527_bypass_helpdesk.mp3. When I attempt to connect my podcast player (www.doncrawley.com/podcast-list) to the feed (https://www.doncrawley.com/feed/podcast/), I get the error “Your podcast couldn’t be embedded. Please double check your URL.” I checked the feed and, to my amateur eyes, it looks okay.

    • This reply was modified 4 years ago by bepositiv.
    • This reply was modified 4 years ago by bepositiv.
    Thread Starter bepositiv

    (@bepositiv)

    Okay, I found tools and diagnostics. Apologies for missing it.

    Here’s what it said:

    Your web server supports the PHP cURL library. Your web server is also configured with the php.ini setting ‘allow_url_fopen’ enabled, but the cURL library takes precedence.

    If you are still having problems detecting media information, check with your web hosting provider if there is a firewall blocking your server.

    allow_url_fopen: true
    curl: true
    curl_ssl: true
    openssl: true

    Plugin Author Angelo Mandato

    (@amandato)

    Hello @bepositiv,

    Awesome, curl and curl_ssl is good.

    I was able to get your media URL to verify fine from our dev sandbox as well as our production website.

    If you have SSH access to your server, please shell into it then try the following command to see if the issue can be replicated outside of WordPress:

    curl -I https://www.doncrawley.com/podcasts/20200527_bypass_helpdesk.mp3

    If you cannot do this, please ask your web hosting to try this test. This will confirm the issue is local on your server. It is completely possible that when trying to access itself it is not getting the same SSL handshake as the public gets.

    Thanks,
    Angelo

    Thread Starter bepositiv

    (@bepositiv)

    Good morning Angelo,

    Thanks for replying on a Sunday morning!

    I ran the command and here are the results:
    doncrawl@usm24 [~]# curl -I https://www.doncrawley.com/podcasts/20200527_bypass_helpdesk.mp3
    curl: (35) error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

    Plugin Author Angelo Mandato

    (@amandato)

    Wow fast response, and great!

    Your next step is to contact your web hosting, tell them you shelled into your server and ran the following command, which proves this is not an exclusive problem with the podcasting plugin or WordPress site, but it appears to be a server specific issue.

    curl -I https://www.doncrawley.com/podcasts/20200527_bypass_helpdesk.mp3

    Also if you have access to another server or your own Mac/Linux computer, you can try this command there, I suspect it works as it does for me. The issue is more than likely a looping back one specific for the web hosting’s setup.

    Thanks,
    Angelo

    Thread Starter bepositiv

    (@bepositiv)

    Thank you, Angelo. You’ve been very helpful. It turned out to be a problem with Cloudflare CDN. I deactivated it and now everything is working well. I appreciate your help!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘sslv3 alert handshake failure’ is closed to new replies.