Support » Plugin: Slim Stat Analytics » SSL Tracking Not Working

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello? Any help here? I don’t see it in your FAQ’s and if I missed it please direct me.

    Question is, how do I enable SlimStats to track my logged in subscribers on HTTPS (SSL) as well as non subscribbed HTTP (non SSL). Surely I’m not the only one with this issue? Or is there not a fix for it?

    Thanks again.

    Plugin Author Jason Crouse

    (@coolmann)

    Marking as resolved.

    Before you close it, just wanted to explain how we got it to work in case other’s bump into this same issue.

    The issue was we installed a SSL certificate and slimstats was not recording anything on https, only http.

    After you took a look at our site, you proposed “the issue is related to the cookie generated by WordPress (not WP SlimStat) and assigned to your ‘known’ visitors. If the cookie is not secure, it will not be sent back to the server via HTTPS, and thus WP SlimStat will not be able to access that information.”

    Thinking that through and after some testing we discovered it was all the sessions that were not recording correctly. So we would loose anyone after login.

    So we first used .htaccess to make sure all pages are forced to https. After that we manually configured WordPress setting the home to https//url.com and updated everything to load/link over https. By doing this we forced the website to naturally utilize https only on it’s own without any rewrites or redirects. Slimstats is now working showing everything again like it did before the certificate was installed.

    Anyway – thanks for the assistance. We’re up and running again.

    Plugin Author Jason Crouse

    (@coolmann)

    Thank you for reporting back and sharing this useful piece of information! A vote for WP SlimStat would be a nice way to say thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘SSL Tracking Not Working’ is closed to new replies.