Support » Plugin: Jetpack by » SSL timeout and performance problems.

  • Resolved OllieJones


    It looks like the latest Jetpack 2.0.2 setup for connecting to wordpress is failing. This is a connection established between the Jetpack code running on the machine hosting, and the

    The message is this, and it takes about 83 seconds to appear.

    Jetpack could not contact register_http_request_failed. This usually means something is incorrectly configured on your web host. SSL connection timeout

    I’ve had support tix in to both and to my hosting provider ( as it happens), and they can’t figure it out.

    It’s possible things have been troublesome for a long time. When I deactivated Jetpack, my wordpress installation’s admin performance shot way WAY up.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I am having the same problems. I have tried everything. I also, checked and made sure I still had a account. Not sure what is going on. I contacted Fatcow and I received the same answer you did. If you get this up and running please share.

    Same issue, same host. I thought it was just me since there were no complaints here in the forum. I noticed a few days ago that my stats stopped working. I thought maybe the connection was a little wonky so I disconnected and got this error when I tried to reconnect.

    I think the issue may be on Fatcow’s side (or Cloudflare’s if we all have that in common as well). I tried older versions of the plugin and they all fail to connect.

    On a side note, if anybody is using the facebook for wordpress plugin, I found that once jetpack was deactivated, a few issues I had with the facebook plugin were resolved as well :/ go figure.

    My site is

    In response to this problem with Jetpack, I created a plugin called Shortpack.

    It contains Jetpack’s code for shortcodes. This allows my installations to keep delivering media with [audio] and [flickr] tags and the like without needing to have Jetpack working and connecting.

    Just was on chat with fatcow. They resolved the issue.. took some time. Suggestion is to use IE clear all of cookies and stuff and then try. However, I did try this and it didn’t work for me, but it worked for them. go figure.. Anyway, it works.

    Fatcow told me, on a trouble ticket on their web site, that they were having their network engineering team look into the problem. That sounds promising. This is most likely some kind of complex inter-network boundary gateway protocol routing problem. The network engineers are the ones who can fix it.

    Using IE and clearing out cookies? Sorry, that’s pure rubbish. Typical untrained first-line support “just boot it” hogwash. This is a problem of connectivity between the Fatcow data center and the WordPress data center. It has nothing to do with your browser client, or mine, at the edge of the network.

    But, my site was having some real performance problems and disabling Jetpack made them go away. (That’s why I bothered to whip up “Shortpack.”)So I’m going to think twice about re-enabling Jetpack even if Fatcow and WordPress can re-establish connectivity.

    Something must have changed as I’m able to connect again.

    At 10:07 EST today 28-Nov-2012, Fat Cow told me they had resolved the problem., FYI. I agree, things are working again.

    Here’s what the tech specialist responded when I asked for an explanation of what they had to fix.

    “We can only say that we had to change the SNAT IP addresses for your account to fix the issue. Unfortunately, we cannot elaborate on the the reasons for the issue due to security reasons.”

    SNAT = source network address translation.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘SSL timeout and performance problems.’ is closed to new replies.