Support » Theme: Storefront » SSL theme compatibility

  • Resolved lphb

    (@luanphilipe)


    I have a problem where users can access via http my store.

    My provider told me to install the plugin: Really Simple SSL to enforce security.

    I was wondering if this is the best way and if I can do it, because the plugin talks about the compatibility of themes with http references for image files, css and js or scripts of a domain without SSL.

    I would like to know if you have full compatibility so I can proceed with the activation of the Plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hey @luanphilipe

    It’s entirely up to you if you want to use that plugin or any other method.

    Keep in mind that with Really Simple SSL, you still need to take care of your own SSL Certificate, before configuring the plugin.

    You may want to check with your host if they offer this in your hosting package, which might be a bit easier.

    Hi @luanphilipe,

    I also wanted to follow up, just to reiterate my friend Senff, your hosting provider should likely be the one who installs and sets up an SSL certificate for your site/domain.

    If you can then access your site via HTTPS then I would also head into your WordPress settings and change the URLs under Settings > General.


    Link to image: https://cld.wthms.co/0mH90j

    Using HTTPS here will force all pages to load over HTTPS using your SSL certificate. The mentioned Really Simple SSL plugin will help make sure any other assets like images in posts, etc… load over HTTPS as well.

    Nonetheless, Storefronte will work just fine no matter how you get your site to use HTTPS. 🙂

    lphb

    (@luanphilipe)

    Thank you for your attention @senff and @ryanr14 .

    Before if the domain was entered without https the site accepted the unsecured connection.

    I forced to use https with plugin and now everything is great.

    Full compatibility.

    Thanks

    Howdy @luanphilipe,

    Well done, that gets a WOO from me. 🙂

    Tseten D

    (@tibetanitech)

    I’m glad you were able to fix this problem. I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.