Support » Fixing WordPress » SSL problem while editing page

  • rajibrihan

    (@rajibrihan)


    Hello
    The pages working perfectly in front-end. But when editing the page at back-end it looks unsecured.

    Why this problem occurs?

    Thank you

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Look in your browser’s error console. Do you see any mixed content messages?

    Learn to use the Chrome Developer Tools or Firefox Developer Tools.

    rajibrihan

    (@rajibrihan)

    Hello
    Another website is working perfectly. So browser is not an issue

    Thank you

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    That’s not what I said. Look at your browser’s error console.

    akkiorg

    (@akkiorg)

    Hi,
    Please note that I am experiencing this issue all the time as my websitessomehow become “Not Secured” for some reason even when a valid SSLcertificate (Lets Encrypt) is installed on them. Furthermore, my WordPress URL and Site Addresses are grayed out in WP General Setting therefore I cannot change it HTTP to HTTPS.

    When I submitted the above issue to the Bitnami Community (Wordrpess) they sent me the link (https://docs.bitnami.com/aws/apps/wordpress/administration/configure-domain/) and recommended to make following changes in Cobfug file:

    Configure The WordPress Domain Name
    If you are using WordPress v3.3.1-5 or higher, only specify your domain name in the /opt/bitnami/apps/wordpress/htdocs/wp-config.php file. Edit and replace the following lines as shown, remembering to replace the DOMAIN placeholder with the actual domain name you wish to use:

    define(‘WP_SITEURL’, ‘http://’ . $_SERVER[‘HTTP_HOST’] . ‘/’);
    define(‘WP_HOME’, ‘http://’ . $_SERVER[‘HTTP_HOST’] . ‘/’);

    with

    define(‘WP_SITEURL’, ‘http://DOMAIN/’);
    define(‘WP_HOME’, ‘http://DOMAIN/’);

    I deleted the original lines and replaced them with the new ones as instructed and press Ctrl+X followed by “Y” to save it and closed the session. When I open a SSH session again, the two original lines were still there, while new ones were not.
    It seems the they never got saved.

    Your assistance required please.

    Rregards

    akkiorg

    (@akkiorg)

    Please ignore the #8217 in both the links .

    define(‘WP_SITEURL’, ‘http://’ . $_SERVER[‘HTTP_HOST’] . ‘/’);
    define(‘WP_HOME’, ‘http://’ . $_SERVER[‘HTTP_HOST’] . ‘/’);

    with

    define(‘WP_SITEURL’, ‘http://DOMAIN/’);
    define(‘WP_HOME’, ‘http://DOMAIN/’);

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.