Support » Fixing WordPress » SSL on certain wordpress pages

  • Resolved artcoder

    (@artcoder)


    I’m using search engine friendly urls and want to force certain wordpress pages to be SSL. When I made the attempt, internet explorer is popping up dialog saying page has mixed secured and unsecured items. This is because at the top of the page wp_enqueue_script is adding script tags that references http://www.example.com/ etc etc. for various plugins.

    How can I make the wp_enqueue_script or the plugins to write URL using https instead of http?

Viewing 2 replies - 1 through 2 (of 2 total)
  • This is an easy way of doing it, and I’m sure that someone will have a better way, but here goes:

    In the Settings section of your blog. Instead of having blog and site address as http://www.your-domain.com, just have them as /

    This will force a relative path, and SSL should have no problems picking it up.

    Didn’t work. When i put in slash, wordpress gave error “The WordPress address you entered did not appear to be a valid URL. Please enter a valid URL.” Same thing with site url.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘SSL on certain wordpress pages’ is closed to new replies.