WP User Avatar
[resolved] SSL issues (mixed secure/unsecure content) (5 posts)

  1. barfoo
    Posted 1 year ago #

    Hi there,

    we are using wordpress with force_ssl_admin beeing enabled (see here: http://codex.wordpress.org/Administration_Over_SSL). Looks like this plugin has issues if this is enabled. If I upload an avatar image and choose it in my profile the browser will issue warnings that the page contains secure and unsecure content. Looks like this is caused by the avatar image beeing displayed in the upper right.

    I'm not sure if this is caused by https://core.trac.wordpress.org/ticket/15928

    Would be great if this could be fixed as this is a pretty awesome plugin ;-)

    All the best



  2. Bangbay Siboliban
    Posted 1 year ago #

    Is this happening for you as an administrator?

  3. barfoo
    Posted 1 year ago #

    As an administrator as well as an user. As soon as I upload an avatar and as soon as its icon is displayed in the upper right corner the browser complains about the mixed secure/unsecure content on all pages served with HTTPS (e.g. edit profile page etc.). If I check the html the uploaded avatar images is linked to as HTTP instead of HTTPS).

    But if this is not a known common issue or not easily reproducable it might as well be related to my theme.

  4. Bangbay Siboliban
    Posted 1 year ago #

    Do you also get the secure/insecure content message when you view your Media Library? If so, it seems like it is related to how attachment URLs are constructed by WordPress.

  5. barfoo
    Posted 1 year ago #

    Yes, I also get the message in the Media Library. It might be related to the wordpress bug listed above.

    Until it gets fixed http://wordpress.org/plugins/ssl-insecure-content-fixer/ works as a workaround for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP User Avatar
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic