Support » Fixing WordPress » SSL is not working with non-admin users

  • Resolved Sneeit.Com

    (@tien-nguyen)


    Hello.

    After installing WordPress on my domain, I notice that my site is not secured.
    Then I try to read $_SERVER[“HTTPS”] variable and it’s strange.

    It returns ON if I logged in with admin account
    It returns OFF if I logged out or logged in with a non-admin account.

    This lead to the following functions work wrong:

    is_ssl()
    set_url_scheme()
    content_url()
    get_theme_root_uri()
    get_template_directory_uri()

    I appreciate any help that point out what is happening with my site.

    Thank you very much.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    Please remove your coming soon plugin so we can see your site.

    Hi

    Your site is secured and shows padlock with https in all the links in your homepage. Didn’t understand as its not English.

    Thread Starter Sneeit.Com

    (@tien-nguyen)

    Thank all you guy very much.

    I removed W3 Total Cache which changed my wp-config.php and .htaccess file, then I restored back those file and everything works well again.

    Appreciate!

    • This reply was modified 1 year, 9 months ago by Sneeit.Com.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘SSL is not working with non-admin users’ is closed to new replies.