Support » Fixing WordPress » SSL – Homepage not secure – Rest of site is

  • Resolved canvas97

    (@canvas97)


    My site is hosted on Network Solutions. I’ve purchased SSL thru them. They set it up on my site.

    When I bring up my site in a browser, the homepage is not secure, however, the rest of the pages in the site are secure.

    I submitted a ticket to them and got this back:

    “I am sorry for any issues you had with your SSL. The reason the lock is not showing on your secure page(s) or you are getting security alerts (depending on what browser you use and security settings in it), is due to the fact that you have code linking to non-secure content. Until you correct this, your site will cause security alerts … “

    Is this an issue I need to continue to work out with Network Solutions ($$$) or can this be resolved somehow by adding code to my homepage thru Word Press?

    I installed ‘SSL Insecure Content Fixer’ and got this message:

    Your server environment shows this:
    Error
    Forbidden

    Any help / direction will be greatly appreciated – Eric

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    This is the issue:

    Mixed Content: The page at 'https://customcanvasalaska.com/' was loaded over HTTPS, but requested an insecure image 'http://customcanvasalaska.com/wp-content/uploads/2017/11/Plate-Cover-99705-small.jpg'. This content should also be served over HTTPS.
    (index):251 Mixed Content: The page at 'https://customcanvasalaska.com/' was loaded over HTTPS, but requested an insecure image 'http://customcanvasalaska.com/wp-content/uploads/2017/11/Plate-Cover-Cinderella-small.jpg'. This content should also be served over HTTPS.
    jquery.js?ver=1.12.4:5 Mixed Content: The page at 'https://customcanvasalaska.com/' was loaded over HTTPS, but requested an insecure image 'http://customcanvasalaska.com/wp-content/uploads/2017/11/Blue_Sky.jpg'. This content should also be served over HTTPS.

    Try using the plugin “better search replace”. Search for http://customcanvasalaska.com and replace with https://customcanvasalaska.com.

    If you do any caching, clear the cache(s).

    THANK YOU

    That plug-in found 62 instances to replace, so I had it replace them.

    Unfortunately, my homepage still did not load into the browser as secure

    I proceeded to turned off plug-ins one by one and test along the way ………. Turns out Elementor was causing this issue due to the fact I had it set up wrong.

    Elementor / Tools / Replace URL – I needed to ‘Update Site Address (URL) – I had to change http://old-url.com to https://new-url.com.

    What a difference one letter can make …. All is now good.

    Thank you for helping me – Your guidance led me in the proper direction. Computers are great, but, thank heavens for human help!

    I’ve marked this as resolved.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘SSL – Homepage not secure – Rest of site is’ is closed to new replies.