Support » Fixing WordPress » SSL Cert – Site not private

  • Hello, we have an SSL cert installed by our host for our website, I am still getting a security issue when on our site, eg Safari – and Your connection to this site is not fully secure.
    Our hosting company is saying if there are links on our site who are using http and not https this is the problem, there is not a lot we can do about this as these are our clients and are paying to be on our site. What is the point of having an SSL cert if this is going to happen, can anyone help please.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • The problem is that you have images pointing to http, and should point to https. Your hosting assures that your web is https, but if you have loaded images pointing to http, you have to manually correct them.

    For example, the image of your logo is pointing to http, which is why it tells you that the web is not completely secure. That also happens to you with other images that you have loaded.

    Rajan V

    (@rajanit2000)

    Hi @mcd-media-ltd.,

    These images are point to http so its come that warning sign, You need to update it.

    Mixed Content: The page at 'https://irishconstruction.com/' was loaded over HTTPS, but requested an insecure image 'http://irishconstruction.com/wp-content/uploads/2017/11/Mayjuneicim2017.jpg'. This content should also be served over HTTPS.
    (index):675 Mixed Content: The page at 'https://irishconstruction.com/' was loaded over HTTPS, but requested an insecure image 'http://irishconstruction.com/wp-content/uploads/2017/12/2016cover.jpg'. This content should also be served over HTTPS.
    (index):1 Mixed Content: The page at 'https://irishconstruction.com/' was loaded over HTTPS, but requested an insecure image 'http://irishconstruction.com/wp-content/uploads/2017/06/ImageBackground.jpg'. This content should also be served over HTTPS.
    (index):1 Mixed Content: The page at 'https://irishconstruction.com/' was loaded over HTTPS, but requested an insecure image 'http://irishconstruction.com/wp-content/uploads/2017/12/ConstructionMenPic.jpg'. This content should also be served over HTTPS.

    Thanks for the replies and help. I have looked at those images, they are coming up with https when i look at image name. What do you mean ‘ the images are pointing to http’, will I have to manually upload images again? and if so are they best uploaded as gifs. thanks.

    Rajan V

    (@rajanit2000)

    This image load from http not https

    http://irishconstruction.com/wp-content/uploads/2017/11/Mayjuneicim2017.jpg

    Can you find it
    under “TOP COMPANIES ISSUE 2017” title

    Hi, Thanks for that, I figured out i how to change link to https in widget side panel. I am still getting ‘this connection is not private’ in browser safari. I have cleared history and cache etc. Any ideas?

    Hello, I am still having an issue with HTTP and HTTPS, I have viewed source and get this at the top of website home page

    <!– Always force latest IE rendering engine (even in intranet) & Chrome Frame –>
    <!–[if IE ]>
    <meta http-equiv=”X-UA-Compatible” content=”IE=edge,chrome=1″>
    <![endif]–>

    I presume this is the issue, is all I have to do is just add s and the end of http, I don’t want to do something that will mess up my website.

    thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.