Support » Plugin: ZodiacPress » SSL and Cities not populating

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author isabel104

    (@isabel104)

    1. This forum is not allowed to be used for the paid plugin. This is only for the free ZodiacPress plugin. (For the paid plugin, request support on the site which you bought it.) However, it looks like your issue is with the free ZodiacPress plugin, so this is okay.

    2. Have you done the pre-support self-check?

    3. Please post your System Info from the self-check or, if possible, a link to your site.

    4. It looks like you may be using the ZodiacPress Enhanced GeoNames plugin. If you are, please disable that plugin because it only works on HTTPS sites that are paying for a GeoNames premium account. Disabling the ZP Enhanced GeoNames plugin should fix your issues (if you are currently using it).

    vilanova

    (@vilanova)

    Hello,

    thank you very much for your answer. I bought GeoNames premium account but I still have the same problem: the list of cities does not populate at all and I get the same error:
    Failed to load resource: net::ERR_CERT_COMMON_NAME_INVALID

    my System Info:
    ### Begin System Info ###

    — Server Info

    Server Software: Apache
    PHP Version: 5.6.10
    GD Support: okay
    PHP_SHLIB_SUFFIX: so
    exec() Function: okay
    chmod() Function: okay

    — ZodiacPress Info

    swetest file: okay
    Ephemeris permissions: okay
    Atlas: GeoNames

    — WordPress Info

    WP Version: 4.9.6
    Multisite: No
    WP_DEBUG: Disabled
    WP Memory Limit: 96M

    — Theme

    Theme Name: Tetris
    Theme Version: 1.0
    Is Child Theme: No

    — Active Plugins

    Akismet Anti-Spam by Automattic version 4.0.3,
    Automatic Facebook Cache Cleaner by Ricardo Salta version 1.0,
    Contact Form 7 by Takayuki Miyoshi version 5.0.1,
    Campos Personalizados by Hiroaki Miyashita version 2.3.8,
    Custom Profile Fields by Thais Vilanova version 0.1,
    Display PHP Version by David Gwyer version 1.4,
    Lightbox Plus ColorBox by Dan Zappone version 2.6,
    Link Manager by WordPress version 0.1-beta,
    Options Framework by Devin Price version 1.8.5,
    Post Tags and Categories for Pages by curtismchale version 1.4.1,
    Query Posts by Justin Tadlock version 0.3.2,
    Really Simple SSL by Rogier Lankhorst version 2.5.26,
    Regenerate Thumbnails by Alex Mills (Viper007Bond) version 3.0.2,
    Responsive Select Menu by Chris Mavricos, SevenSpark version 1.7,
    Reveal IDs by Oliver Schlöbe version 1.5.2,
    Simple Page Ordering by Jake Goldman, 10up version 2.3.2,
    Simple Share Buttons Adder by Simple Share Buttons version 7.4.18,
    Simple Tags by Amaury BALMER version 2.4.7,
    Sticky Posts – Switch by Markus Froehlich version 1.7,
    Category Order and Taxonomy Terms Order by Nsp-Code version 1.5.3.2,
    Open Graph for Facebook, Google+ and Twitter Card Tags by Webdados version 2.2.4.1,
    WooCommerce PagSeguro by Claudio Sanches version 2.12.6,
    WooCommerce by Automattic version 3.3.5,
    Wordfence Security by Wordfence version 7.1.6,
    WP Fastest Cache by Emre Vona version 0.8.7.9,
    WP Smush by WPMU DEV version 2.7.8,
    WP User Avatar by flippercode version 2.0.9,
    YourChannel by Plugin Builders version 0.9.6,
    ZodiacPress by Isabel Castillo, Cosmic Plugins version 1.8.1,
    ZodiacPress Enhanced GeoNames by Isabel Castillo version 1.6,
    ZodiacPress Sell Reports by Isabel Castillo version 1.2

    ### End System Info ###

    thanks a lot

    Plugin Author isabel104

    (@isabel104)

    This error ERR_CERT_COMMON_NAME_INVALID isn’t from the plugin. It’s an error given by the browser when it thinks there is a problem with your certificate.

    Possible solutions:

    1. I would disable the addon plugin “ZodiacPress Enhanced GeoNames” because that plugin expects a valid SSL certificate. (Since the browser itself is giving a certificate error, it’s likely that the Enhanced GeoNames plugin is running into the same error.) Disabling this plugin may resolve the problem. Although, I really do not think this will solve the issue because since your SSL certificate is appearing as “invalid” to the browser, this problem will persist until your SSL certificate issue is cleared up.

    2. Try the form in other browsers. If you’re using Chrome browser to test the ZodiacPress form, try it in other browsers such as Firefox or Microsoft Edge. If it works in other browsers, this would confirm that the problem is that Google Chrome thinks your SSL certificate has a problem.

    3. Contact your web host (or your SSL certificate provider) to see why the SSL certificate is appearing invalid.

    I hope this helps.

    vilanova

    (@vilanova)

    hi,
    I think the problem is with the address api.geonames.org. I have changed in the plugin code all occurrences of this address to secure.geonames.org, as indicated at http://forum.geonames.org/gforum/posts/list/34990.page
    I think it would be interesting to have this option in the plugin panel, if the person has a GeoNames premium account this change would be made. Now the cities are populating and I am not receiving the error messages anymore.

    thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘SSL and Cities not populating’ is closed to new replies.