Support » Theme: Longform » [ssba] Tag Appearing After Every Post

  • I am currently using the Longform theme on http://www.thegoodgun.com.

    I noticed that the [ssba] tag is showing up after post content and ads, no matter which post you go to. I thought it had something to do with a plugin trying to add sharing buttons after the post. I went under my “Sharing” settings and disabled this, to no avail. I’ve also unchecked the option to use the buttons in individual post settings, and that hasn’t fixed the problem either.

    It’s a minor nuisance, but I would greatly appreciate help in eliminating this erroneous code from my posts! Thanks in advance for any help anyone can offer!

Viewing 6 replies - 1 through 6 (of 6 total)
  • swekarl

    (@swekarl)

    Just installed this beautiful theme to try it out, and I got exactly the same problem.

    My solution: Copy the file single.php to your child theme and edit it. Search for the phrase [ssba] and delete it from within the single quotes.

    • This reply was modified 11 months, 2 weeks ago by  swekarl. Reason: quotes not displaying correctly

    [ssba] is a short code for the plugin Simple Shared Buttons. So you can either install and use that plugin or remove it by altering a child theme as suggested above by swekarl.

    Unfortunately the theme has the plugin features integrated.

    I’ve never had any luck getting child themes to actually work, be it by following a tutorial or using a plugin to do it.

    I’m using child themes with this theme on two wordpress projects. I have five wordpress projects in total, three using other themes and child themes. I’m not a IT person, just someone who finds it fun to dable in code (self-taught) but this is what I set up below. I think this might be the old way… I’m not sure. I will probably have to check this myself in coming weeks.

    Using my ftp client CoffeeCup Direct FTP
    I created a new folder under themes called longform-child
    I then created a new file in this folder called style.css

    I then added this code (change to suit yourself)

    /*
    Theme Name: Longform_Child
    Theme URI: http://tinadubinsky.com/themes/longform-child
    Author: Tina Dubinsky
    Author URI: http://tinadubinsky.com
    Description: This is a child template for longform
    Version: 1.1.0
    License: GNU General Public License v2 or later
    License URI: http://www.gnu.org/licenses/gpl-2.0.html
    Text Domain: longform
    Template: longform
    Domain Path: /languages/
    Tags: light, responsive-layout, two-columns, custom-header, full-width-template, post-formats, sticky-post, editor-style, custom-colors, threaded-comments, translation-ready
    */
    
    @import url("../longform/style.css");

    Then, to remove the SSBA code above you’ll need to copy the file single.php to your child theme directory. In the example below I’ve also commented out the reference to the aesop sharing plugin which is an additional paid feature of aesop.

    Goto line: 36 and comment out the following lines of code (line 36 – 40 inclusive)

    //if ( defined('BA_AESOPSOCIAL_ITEM_NAME') && BA_AESOPSOCIAL_ITEM_NAME == 'aesop-social' ) {
    	//do_action('ase_addon_social_links');
     //} else {
     	//echo do_shortcode( '[ssba]' );
     //}

    If you’re like me and there’s only a single author on the site, you may also want to comment out the reference to the author meta (lines 42-44 inclusive)

    //if ( get_the_author_meta( 'description' ) ) :
          //get_template_part( 'author-bio' );
     //endif;

    I hope this helps somewhat. (also hoping I’ve used the tags in this post correctly)

    Have a happy new year.

    • This reply was modified 10 months, 3 weeks ago by  Dubsy. Reason: adding line numbers

    Commenting it out didn’t fix the issue, but it did get me pointed in the right direction. I ended up removing the code entirely and it appears to have fixed the issue. Thanks for your help! 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[ssba] Tag Appearing After Every Post’ is closed to new replies.